美文网首页
PAT 甲级 刷题日记|A 1066 Root of AVL

PAT 甲级 刷题日记|A 1066 Root of AVL

作者: 九除以三还是三哦 | 来源:发表于2021-08-15 09:33 被阅读0次

题目

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

1628843473851.png

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120
结尾无空行

Sample Output 1:

70
结尾无空行

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

思路

平衡二叉树,考法很直接,模板很固定

代码

#include <bits/stdc++.h>
using namespace std;

struct node{
    int v, height;
    node *lchild, *rchild;
    node(int data): v(data), height(1), lchild(NULL), rchild(NULL) {
    }
};


int getHeight(node* root) {
    if (root == NULL) return 0;
    return root->height;
}

void updateHeight(node* root) {
    root->height = max(getHeight(root->lchild), getHeight(root->rchild)) + 1;
}

int getBalanceFactor(node* root) {
    return getHeight(root->lchild) - getHeight(root->rchild);
}

void L(node* &root) {
    node* temp = root->rchild;
    root->rchild = temp->lchild;
    temp->lchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;    
} 

void R(node* &root) {
    node* temp = root->lchild;
    root->lchild = temp->rchild;
    temp->rchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;
}

void insert(node* &root, int v) {
    if (root == NULL) {
        root = new node(v);
        return;
    }
    if (v < root->v) {
        insert(root->lchild, v);
        updateHeight(root);
        if (getBalanceFactor(root) == 2) {
            if (getBalanceFactor(root->lchild) == 1) {
                R(root);
            } else if (getBalanceFactor(root->lchild) == -1) {
                L(root->lchild);
                R(root);
            }
        }
    } else {
        insert(root->rchild, v);
        updateHeight(root);
        if (getBalanceFactor(root) == -2) {
            if (getBalanceFactor(root->rchild) == -1) {
                L(root);
            } else if (getBalanceFactor(root->rchild) == 1) {
                R(root->rchild);
                L(root);
            }
        }
        
    }
}

int main() {
    int n;
    int data[10000];
    cin>>n;
    node* root = NULL;
    for (int i = 0; i < n; i++) {
        cin>>data[i];
        insert(root, data[i]);
    }
    cout<<root->v<<endl;
}

相关文章

网友评论

      本文标题:PAT 甲级 刷题日记|A 1066 Root of AVL

      本文链接:https://www.haomeiwen.com/subject/aifjbltx.html