美文网首页
hduoj water~~~1070

hduoj water~~~1070

作者: 翘尾巴 | 来源:发表于2017-02-02 13:51 被阅读0次

    Problem Description
    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:

    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

    Output
    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

    Sample Input
    2
    2
    Yili 10 500
    Mengniu 20 1000
    4
    Yili 10 500
    Mengniu 20 1000
    Guangming 1 199
    Yanpai 40 10000

    Sample Output
    Mengniu
    Mengniu

    有几处细节要考虑

    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cmath>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    const double eps=1e-9;
    using namespace std;
    struct Milk{
        string name;
        int p;
        int v;
        int days;
        double dailycost;
    };
    Milk milks[100];
    int cmp(Milk m1,Milk m2){
        if(fabs(m1.dailycost-m2.dailycost)>eps){
            return m1.dailycost<m2.dailycost;
        }else{
            return m1.v>m2.v;
        }
    }
    int main(){
        int t,n;
        scanf("%d",&t);
        while(t--){
            int k=0,flag=0;
            scanf("%d",&n);
            for(int i=0;i<n;i++){
                cin>>milks[i].name>>milks[i].p>>milks[i].v;
            }
            for(int i=0;i<n;i++){
                milks[i].days=milks[i].v/200;
                if(!milks[i].days){
                    k++;
                    flag=1;
                    milks[i].dailycost=0;
                }else {
                    if(milks[i].days>5){
                        milks[i].days=5;
                    }
                    milks[i].dailycost=milks[i].p*1.0/milks[i].days;
                }
            }
            sort(milks,milks+n,cmp);
            if(flag){
                cout<<milks[k].name<<endl;
            }else{
                cout<<milks[0].name<<endl;
            }
        }
        return 0;
    }
    
    
    ``````````
    
    
    
    

    相关文章

      网友评论

          本文标题:hduoj water~~~1070

          本文链接:https://www.haomeiwen.com/subject/arcrittx.html