美文网首页
自测-4 Have Fun with Numbers(20 分)

自测-4 Have Fun with Numbers(20 分)

作者: 末央酒 | 来源:发表于2017-12-04 13:16 被阅读0次

    Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

    Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

    Input Specification:

    Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

    Output Specification:

    For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

    Sample Input:

    1234567899
    Sample Output:

    Yes
    2469135798

    import java.math.BigInteger;
    import java.util.Scanner;
    
    
    public class Main{
        public static boolean judge(String nums,String doubled){
            char []exaclty = new char[10];
            if (nums.length() != doubled.length()) {
                return false;
            }
            for (int i = 0; i < nums.length(); i++) {
                int num = nums.charAt(i) - '0';
                exaclty[num]++;
            }
            for (int i = 0; i < doubled.length(); i++) {
                int num = doubled.charAt(i)-'0';
                exaclty[num]--;
            }
            for (int i = 0; i < exaclty.length; i++) {
                if (exaclty[i] != 0) {
                    return false;
                }
            }
            return true;
        }
        public static void main(String[] args) {
            Scanner in = new Scanner(System.in);
            String nums = in.next();
            BigInteger doubling = new BigInteger(nums);
            doubling = doubling.shiftLeft(1);
            String doubled = String.valueOf(doubling);
            if (judge(nums,doubled)) {
                System.out.println("Yes");
            }else{
                System.out.println("No");
            }
            System.out.println(doubling);
        }
    }
    
    

    相关文章

      网友评论

          本文标题:自测-4 Have Fun with Numbers(20 分)

          本文链接:https://www.haomeiwen.com/subject/bfxxixtx.html