美文网首页
2020-03-30

2020-03-30

作者: joker_luo | 来源:发表于2020-03-30 21:24 被阅读0次

    1086 Tree Traversals Again (25分)

    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

    [图片上传失败...(image-36d4ad-1585574665319)]
    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    
          
        
    

    Sample Output:

    3 4 2 6 5 1
    
    #include<iostream>
    #include<vector>
    #include<stack>
    #include<cstring>
    using namespace std;
    vector<int> pre,mid,back;
    void postorder(int root,int start,int end){
        if(start>end){
            return;
        }
        int i = start;
        while(i<end && mid[i]!=pre[root]){
            i++;
        }
        postorder(root+1,start,i-1);
        postorder(root + 1 + i - start,i+1,end);
        back.push_back(pre[root]);
    }
    int main(){
        int node;
        stack<int> stack;
        cin>>node;
        string s;
        int m;
        for(int i=0;i<2*node;++i){
            cin>>s;
            if(s[1] == 'u'){
                cin>>m;
                pre.push_back(m);
                stack.push(m);
            }else{
                mid.push_back(stack.top());
                stack.pop();
            }
        }
        postorder(0,0,node-1);
        printf("%d",back[0]);
        for(int i=1;i<back.size();++i){
            printf(" %d",back[i]);
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:2020-03-30

          本文链接:https://www.haomeiwen.com/subject/biubuhtx.html