美文网首页
HDU 2025 查找最大元素

HDU 2025 查找最大元素

作者: itbird01 | 来源:发表于2022-04-27 07:06 被阅读0次

    Problem Description
    对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

    Input
    输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

    Output
    对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

    Sample Input

    abcdefgfedcba xxxxx

    Sample Output

    abcdefg(max)fedcba x(max)x(max)x(max)x(max)x(max)

    Author
    lcy

    java code

    import java.io.BufferedInputStream;
    import java.util.Scanner;
    
    public class Main{
    
        /**
         * TODO
         * @return_type void
         * @param args
         */
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner s = new Scanner(new BufferedInputStream(System.in));
            String str = null;
            char c;
            while(s.hasNext()) {
                str = s.next();
                c = str.charAt(0);
                for(int i=1; i<str.length(); ++i) {
                    if(c < str.charAt(i)) {
                        c = str.charAt(i);
                    }
                }
                for(int i=0; i<str.length(); ++i) {
                    System.out.print(str.charAt(i));
                    if(str.charAt(i) == c) {
                        System.out.print("(max)");
                    }
                }
                System.out.println();
            }
        }
    
    }```

    相关文章

      网友评论

          本文标题:HDU 2025 查找最大元素

          本文链接:https://www.haomeiwen.com/subject/blbtsrtx.html