美文网首页Poj
Poj 1384 Piggy-Bank

Poj 1384 Piggy-Bank

作者: 86棵梦 | 来源:发表于2017-08-19 11:26 被阅读36次

题目

Poj 1384 Piggy-Bank

Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

具体的内容就是一共有多种硬币,分别给出了每种硬币的重量与价格,然后根据存钱罐的重量,来判断是否可行,如果可行的话,存钱罐中最小的价值是多少。仍然是背包问题。

代码

// http://poj.org/problem?id=1384
#include <stdio.h>
#include <iostream>
#include <bitset>
#include <algorithm>
using namespace std;

struct Coin {
    int value;
    int weight;
};

Coin coinList[505];
int result[50000];

int MAX_RESULT = 50000 * 10000 + 10;

int updateResult(int maxAmount, int coinType) {
    for (int i = 0; i <= maxAmount; i++) {
        result[i] = MAX_RESULT;
    }
    
    result[0] = 0;
    for (int i = 0; i < coinType; i++) {
        int value = coinList[i].value;
        int weight = coinList[i].weight;

        for(int t = weight; t <= maxAmount; t++) {
            result[t] = min(result[t], result[t - weight] + value);
        }
    }
    return result[maxAmount];
}

int main(int argc, const char * argv[]) {
    int test, coinType, emptyWeight, fullWeight;
    scanf("%d", &test);
    for (int i = 0; i < test; i++) {
        scanf("%d %d", &emptyWeight, &fullWeight);
        scanf("%d", &coinType);
        for (int t = 0; t < coinType; t++) {
            scanf("%d %d", &coinList[t].value, &coinList[t].weight);
        }
        int result = updateResult(fullWeight - emptyWeight, coinType);
        if (MAX_RESULT == result) {
            printf("This is impossible.\n");
        } else {
            printf("The minimum amount of money in the piggy-bank is %d.\n", result);
        }
    }
}

相关文章

  • Poj 1384 Piggy-Bank

    题目 Poj 1384 Piggy-Bank 具体的内容就是一共有多种硬币,分别给出了每种硬币的重量与价格,然后根...

  • Chapter9——图——最小生成树

    1. 题目列表 POJ1789(prim算法) POJ2485(prim) POJ1258(prim) POJ30...

  • poj来自群

    OJ上的一些水题(可用来练手和增加自信) (poj3299,poj2159,poj2739,poj1083,poj...

  • Chapter5——数据结构——字符串

    1. 题目列表 poj1035,poj3080,poj1936 2. POJ1035——Spell checker...

  • ACM算法学习状态

    初期:一.基本算法:(1)枚举. (poj1753,poj2965)(2)贪心(poj1328,poj2109,p...

  • 常用技巧合集

    1.尺取法 POJ 3061 POJ3320 POJ 2739 2.反转问题 POJ 3276 集合的整数表示空集...

  • 1384

    农历七月十五 戊戌年庚申月己丑日 今夜月,何年人。 我天生幽默,因为故人说,笑着就不会感到痛苦了。今天是中元节,传...

  • 1384

    清明假期,毕业后第一次和大学上铺的舍友约在南京见面,已经相隔了九个月。 想起毕业离校那天,我是最早离开的,大概早上...

  • Chapter7——基础算法——哈希、二分

    1. 题目列表 POJ3349(数组hash) POJ3274(问题转换+数组hash、树状数组) POJ2151...

  • 计算几何

    极限 POJ 1981: Circle and Points POJ 1418: Viva Confetti题解链...

网友评论

    本文标题:Poj 1384 Piggy-Bank

    本文链接:https://www.haomeiwen.com/subject/cektdxtx.html