美文网首页
【MAC 上学习 C++】Day 61-5. 6-10 阶乘计算

【MAC 上学习 C++】Day 61-5. 6-10 阶乘计算

作者: RaRasa | 来源:发表于2019-10-24 23:12 被阅读0次

6-10 阶乘计算升级版 (20 分)

1. 题目摘自

https://pintia.cn/problem-sets/14/problems/742

2. 题目内容

本题要求实现一个打印非负整数阶乘的函数。

函数接口定义:

void Print_Factorial ( const int N );
其中N是用户传入的参数,其值不超过1000。如果N是非负整数,则该函数必须在一行中打印出N!的值,否则打印“Invalid input”。

输入样例:

15

输出样例:

1307674368000

3. 源码参考
#include <iostream>
#include <iomanip>

using namespace std;

void Print_Factorial ( const int N );

int main()
{
    int N;

    cin >> N;
    Print_Factorial(N);

    return 0;
}

void Print_Factorial ( const int N )
{
  double s;

  s = 1;
  for(int i = 1; i <= N; i++)
  {
    s *= i;
  }

  cout << fixed << setprecision(0) << s << endl;
  
  return;
}

相关文章

网友评论

      本文标题:【MAC 上学习 C++】Day 61-5. 6-10 阶乘计算

      本文链接:https://www.haomeiwen.com/subject/chtbmctx.html