美文网首页
The Suspects POJ - 1611

The Suspects POJ - 1611

作者: 散落的魔王 | 来源:发表于2017-01-18 01:33 被阅读0次

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
    Input
    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
    Output
    For each case, output the number of suspects in one line.
    Sample Input
    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0
    Sample Output
    4
    1
    1
    这道题的题意,简单来说就是SARS病毒很可怕,搞得到处都人心惶惶的。在这里有许多学生小组,为了能够在学生中减少传染,NSYSU定了一个规矩,只要有一个学生是嫌疑者,当前学生所在的小组里的其他所有的学生都是嫌疑者,我们的任务就是找出一共有多少个嫌疑者。(0是嫌疑者,和0在同一个小组的其他人是嫌疑者,而只要有这些人的小组,哪怕只有一个人,这个小组也全是嫌疑者)
    数据:给你一个n和m,表示n个学生,m个小组,接下来首先给定每一个小组的人数,然后给你这个小组的学生名单(也就是一个数字),有多组数据,0 0表示程序可以结束了。
    这道题是一道经典的并查集问题,我的思路是这样,将所有和0直接相关或者间接相关的点全部并在0上,用一个单独的数组记录一个节点的与它相连的节点的个数,然后能加到0上的统一到0上。(解释的不是很清楚,表述能力有限,还是直接看代码吧)
    代码如下:

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #define MAXN 100000
    using namespace std;
    int par[MAXN],peo[MAXN],node[MAXN];
    void init(int n)
    {
        for(int i=0;i<n;i++)
         {
          node[i]=1;//记录与第i个节点连接的节点有多少个(包括本身)
          par[i]=i;
         }
    }
    int find(int x)
    {
        if(par[x]==x)return x;
        return par[x]=find(par[x]);
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)return;
        if(x==0)//有0的话强制和0并在一起
        {
            par[y]=x;
            node[x]+=node[y];//记录每个点的节点个数
            return;
        }
        par[x]=y;
        node[y]+=node[x];
    }
    int main()
    {
    //  freopen("data.in","r",stdin);
        int n,m;
        while(scanf("%d%d",&n,&m))
        {
         if(n==0&&m==0)break;
         init(n);
         while(m--)
         {
            int mem,a;
            bool flag=false;//用来判断一个组是不是有0
            scanf("%d",&mem);
            for(int i=1;i<=mem;i++)
             {
                scanf("%d",&peo[i]);
                if(peo[i]==0)flag=true;
             }
            if(flag)//如果有0
            {
              for(int i=1;i<=mem;i++)
                unite(peo[i],0);//全部和0并在一起
            }
            else {
              for(int i=2;i<=mem;i++)
               unite(peo[i-1],peo[i]);//没有就把一个组的人一个接一个的并起来
            }
         }
         printf("%d\n",node[0]);//0所拥有的与它相连接的节点个数(包括它本身)就是答案
        }
        return 0;
    } 
    

    相关文章

      网友评论

          本文标题:The Suspects POJ - 1611

          本文链接:https://www.haomeiwen.com/subject/cmyvbttx.html