美文网首页
POJ 1611 - The Suspects

POJ 1611 - The Suspects

作者: passwd_ | 来源:发表于2017-07-12 15:33 被阅读0次

POJ 1611 - The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:
n个人,如果有一个人感染了SARS病毒,那么和这个人同组的人都会感染病毒。也就是说和被感染的人有关系的人都感染了病毒。
输入:n m n为成员个数 m为组数
输出:被感染的人数
定义 num[] 数组,num[i] 表示 i 所在集合的元素数量。 初始化 num[] 数组全为 1,每次合并的时候就更新每组代表元素的num[] 值。
最后输出的时候先找到被感染的0号的父节点,然后输出父节点的num[].

解题思路:

  • 定义 num[] 数组,num[i] 表示 i 所在集合的元素数量。
  • 初始化 num[] 数组全为 1,每次合并的时候就更新每组代表元素的num[] 值。
  • 最后输出的时候先找到被感染的0号的父节点,然后输出父节点的num[].
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
const int MAX = 30000;

int fa[MAX], deep[MAX], num[MAX];

void init()
{
    memset(fa, -1, sizeof(fa));
    memset(deep, 0, sizeof(deep));
}

int find(int x)
{
    if (fa[x] == -1) return x;
    return fa[x] = find(fa[x]);
}

void unite(int x, int y)
{
    x = find(x), y = find(y);
    if (x == y) return;
    if (deep[x]<deep[y]) {
        fa[x] = y;
        num[y] += num[x];//y为代表元素 将num[x]里面的数量加到num[y]里
    }
    else
    {
        fa[y] = x;
        if (deep[x] == deep[y])
            deep[x]++;
        num[x] += num[y];
    }
}

bool same(int x, int y)
{
    return find(x) == find(y);
}


int main()
{
    int n, m;
    int k;
    int x, y;
    while (scanf("%d%d", &n, &m) && n != 0 || m != 0) {
        if (n > MAX || m > 500) break;
        init();
        for (int i = 0; i < n; i++)
        {
            num[i] = 1;//初始化num为1
        }
        while (m--) {
            scanf("%d%d", &k, &x);//这里输入 组内成员个数k 和 每组第一个代表元素x
            for (int i = 1; i < k; i++)
            {
                scanf("%d", &y);
                unite(x, y);

            }

        }
        printf("%d\n", num[find(0)]);//先找0的父节点 然后输出集合内元素个数

    }

    return 0;
}

相关文章

  • 再贴一次并查集

    F - The Suspects POJ - 1611

  • POJ 1611 - The Suspects

    POJ 1611 - The Suspects Severe acute respiratory syndrome...

  • POJ——1611 The Suspects

    题目大意 这题将的就是有n个人,被分成m组(每个人可能在几个组里面),其中0号人物肯定是患有非典。而与0号同组的人...

  • The Suspects POJ - 1611

    Severe acute respiratory syndrome (SARS), an atypical pne...

  • POJ-1611 The Suspects

    1、题意## 为了防止SARA传播,NSYSU收集所有学生组的成员列表,一旦群组中的成员是可疑人员,群组中的所有成...

  • POJ 1611

    POJ 1611 题意 有n个人参加了m个社团,同一个社团互相接触的人有感染非典的概率,已知0号同学是疑似病例,求...

  • POJ 1611

    POJ 1611 题意 有n个人参加了m个社团,同一个社团互相接触的人有感染非典的概率,已知0号同学是疑似病例,求...

  • POJ 1611

    The Suspects Severe acute respiratory syndrome (SARS), an...

  • 2019-01-29 [POJ-1611],

    [POJ-1611] include include using names...

  • Volunteers

    They were not real suspects but a couple of students who ...

网友评论

      本文标题:POJ 1611 - The Suspects

      本文链接:https://www.haomeiwen.com/subject/epubhxtx.html