美文网首页
杭电acm2124 Repair the Wall

杭电acm2124 Repair the Wall

作者: cwhong | 来源:发表于2018-06-28 09:39 被阅读0次

Repair the Wall

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5217 Accepted Submission(s): 2506

Problem Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
 
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.
 
One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
 
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
 
Input
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
 
Output
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
 
Sample Input
5 3 3 2 1 5 2 2 1
 
Sample Output
2
impossible

Solution

贪心问题,一块木板尽量多用几次,最后用的总木块数尽量少,所以先将裂缝安小到大排序

Code

/** 
 * date:2017.11.16 
 * author:孟小德 
 * function:杭电acm2124 
 *  Repair the Wall     贪心算法,先最木块进行排序,最大最长的先处理 
 */  
  
  
  
import java.util.*;  
  
public class acm2124  
{  
    public static void main(String[] args)  
    {  
        Scanner input = new Scanner(System.in);  
  
        while (input.hasNextInt())  
        {  
            int L = input.nextInt();  
            int N = input.nextInt();  
  
            // 输入木块长度  
            int[] wood = new int[N];  
            for (int i=0;i<N;i++)  
            {  
                wood[i] = input.nextInt();  
            }  
  
            sort(wood);  
  
            int len = 0;  
            int num = 0;  
            for (int i=0;i<N;i++)  
            {  
                if ((len + wood[i]) < L)  
                {  
                    len += wood[i];  
                    num++;  
                }  
                else  
                {  
                    len += wood[i];  
                    num++;  
                    break;  
                }  
  
            }  
  
            if (len >= L)  
            {  
                System.out.println(num);  
            }  
            else  
            {  
                System.out.println("impossible");  
            }  
        }  
    }  
  
    // 木块长度由大到小排列  
    public static void sort(int[] wood)  
    {  
        boolean flag = true;  
        int temp;  
        for (int i = 0;i<wood.length && flag;i++)  
        {  
            flag = false;  
            for (int j = 0;j<wood.length-i-1;j++)  
            {  
                if (wood[j] < wood[j+1])  
                {  
                    temp = wood[j];  
                    wood[j] = wood[j+1];  
                    wood[j+1] = temp;  
                    flag = true;  
                }  
  
            }  
        }  
    }  
}  

相关文章

  • 杭电acm2124 Repair the Wall

    Repair the Wall Time Limit: 5000/1000 MS (Java/Others) ...

  • 杭电助手

    杭电助手(服务号hduhelp,订阅号hduhelper)是隶属于杭州电子科技大学党委学工部的校级组织,我们有前端...

  • 杭电2015

    这道题看起来不复杂,但做起来还是挺费工夫的。里面要用很多的循环结构,很容易在些小地方出错。我就是因为那些小问题而搞...

  • 杭电打卡

    这题主要是数学方法求解,其他没什么难度,关键是得出递推公式。 假如第一个和最后一个格子能相同颜色,我们可以很快算出...

  • 杭电oj 第11页 java版答案

    杭电oj 第2000- 2099 题 全答案杭电oj 第十一页答案 具体路径在 src/main/java/com...

  • Kortrijk bicycle repair

    Kortrijk bicycle repair, all locations to repair your bik...

  • 杭电ACM1001

    不再更新,杭电ACM的题转到csdn博客

  • Level 3 Unite 3 Part 2 精讲1

    home repair 家居维修home reapir company 家居维修公司repair services...

  • 想谈一场机器人的恋爱

    “Wall....E, Wall...E, Wall...E......” “Eva, Eva, Eva........

  • 杭电ACM(1013)

网友评论

      本文标题:杭电acm2124 Repair the Wall

      本文链接:https://www.haomeiwen.com/subject/dhowyftx.html