美文网首页
杭电acm1548 A string lift

杭电acm1548 A string lift

作者: cwhong | 来源:发表于2018-06-28 09:17 被阅读0次

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28432 Accepted Submission(s): 10231

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
5 1 5 3 3 1 2 5 0
 
Sample Output
3

Solution

这道题用广度优先搜索来解,但是应当注意程序中不要出现死循环,队列中不重复添加已有的楼层

Code

package acm1548;
 
/**
 * date:2017.12.08
 * author:孟小德
 * function:    杭电acm1548
 *      A strange lift
 */
 
import java.util.*;
 
class Node
{
    int floor,num,time;
    public Node(int floor,int num,int time)
    {
        this.floor = floor;
        this.num = num;
        this.time = time;
    }
    public Node()
    {}
}
 
public class Main
{
    public static int N,A,B;
    public static int[] lift;   //记录电梯每层信息
    public static int[] inflag;
 
    public static void BFS()
    {
        Node cur = new Node(A,lift[A],0);
        Queue<Node> nodeQ = new LinkedList<Node>();
        nodeQ.add(cur);
        inflag[A] = 0;
        while (!nodeQ.isEmpty())
        {
            Node nfloor = nodeQ.poll();
            if (nfloor.floor == B)
            {
                System.out.println(nfloor.time);
                return;
            }
            if (nfloor.time > N - 1)
            {
                System.out.println(-1);
            }
 
            int x = nfloor.floor + nfloor.num;
            if (x<=N && inflag[x] == 0)
            {
                inflag[x] = 1;
                nodeQ.add(new Node(x,lift[x],nfloor.time + 1));
            }
            x = nfloor.floor - nfloor.num;
            if (x>=1 && inflag[x] == 0)
            {
                inflag[x] = 1;
                nodeQ.add(new Node(x,lift[x],nfloor.time + 1));
            }
        }
        System.out.println(-1);
    }
 
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);
 
        while ((N = input.nextInt()) != 0)
        {
            A = input.nextInt();
            B = input.nextInt();
 
            lift = new int[N+1];
            inflag = new int[N+1];
            for (int i=1;i<=N;i++)
            {
                lift[i] = input.nextInt();
                inflag[i] = 0;
            }
 
            BFS();
 
        }
    }
}

相关文章

  • 杭电acm1548 A string lift

    A strange lift Time Limit: 2000/1000 MS (Java/Others) ...

  • 杭电助手

    杭电助手(服务号hduhelp,订阅号hduhelper)是隶属于杭州电子科技大学党委学工部的校级组织,我们有前端...

  • 杭电2015

    这道题看起来不复杂,但做起来还是挺费工夫的。里面要用很多的循环结构,很容易在些小地方出错。我就是因为那些小问题而搞...

  • 杭电打卡

    这题主要是数学方法求解,其他没什么难度,关键是得出递推公式。 假如第一个和最后一个格子能相同颜色,我们可以很快算出...

  • 杭电oj 第11页 java版答案

    杭电oj 第2000- 2099 题 全答案杭电oj 第十一页答案 具体路径在 src/main/java/com...

  • Second last

    If you want to lift yourself up lift up someone else. Yes...

  • Lift

    提升自己 若变成逢场作戏 那 最后就是 尊重被跌下神坛 人世间说句 不过如此

  • 杭电ACM1001

    不再更新,杭电ACM的题转到csdn博客

  • 杭电ACM(1013)

  • 二零一七杭电赏梅

    西邻专司花千尊, 东毗惟和草万匀, 纷落梅卿诱草生, 葱绿淡粉妆美人。

网友评论

      本文标题:杭电acm1548 A string lift

      本文链接:https://www.haomeiwen.com/subject/dmgwyftx.html