美文网首页
hdu-1241 Oil Deposits(求子块个数)

hdu-1241 Oil Deposits(求子块个数)

作者: xcpooo | 来源:发表于2018-12-21 19:02 被阅读0次

    Oil Deposits
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3087 Accepted Submission(s): 1765

    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@', representing an oil pocket.

    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input
    1 1

    3 5
    @@*
    @
    @@*
    1 8
    @@****@*
    5 5
    ****@
    @@@
    @@
    @@@
    @
    @@**@
    0 0

    Sample Output
    0
    1
    2
    2

    #include <iostream>
    using namespace std;
    char dp[105][105];
    int c; int k;
    
    
    
    int bfs(int x,int y) {
    
    
        int sum=0;
        if (dp[x][y] == '@') {
            sum++;
            if (y < k) {  dp[x][y] = '*';  sum = sum + bfs(x, y + 1); }
            if (y > 0) {  dp[x][y] = '*';  sum = sum + bfs(x, y - 1); }
            if (x <c) { dp[x][y] = '*';  sum = sum + bfs(x + 1, y); }
            if (x > 0) {  dp[x][y] = '*'; sum = sum + bfs(x - 1, y); }
    
            if (y < k&&x < c) { dp[x][y] = '*';  sum = sum + bfs(x+1, y + 1); }//右下
            if (y < k&&x > 0) { dp[x][y] = '*';  sum = sum + bfs(x-1, y + 1); }//右上
            if (y > 0 && x < c) { dp[x][y] = '*';  sum = sum + bfs(x+1, y - 1); }//左下
            if (y > 0&&x > 0) { dp[x][y] = '*';  sum = sum + bfs(x-1, y - 1); }//左上
        
        }
        return sum;
    }
    
    
    
    void main() {
        
        while (cin >> c >> k && c&&k) {
            memset(dp, 0, sizeof(dp));
            int s1 = 0;
            for (int i = 0; i < c; i++) {
                for (int j = 0; j < k; j++) {
                    cin >> dp[i][j];
                }
            }
    
    
            for (int i = 0; i < c; i++) {
                for (int j = 0; j < k; j++) {
                    if (bfs(i, j) >= 1)s1++;//如果找到了连着的油矿大于0,就说明有油袋
            
                }
            }
    
    
            
            cout << s1<<endl;
        }
    
    }
    
    
    
    
    

    相关文章

      网友评论

          本文标题:hdu-1241 Oil Deposits(求子块个数)

          本文链接:https://www.haomeiwen.com/subject/dmpvkqtx.html