美文网首页
STL hdu1022-Train Problem I

STL hdu1022-Train Problem I

作者: AC丶筱桀 | 来源:发表于2017-10-25 19:31 被阅读0次

    题目链接:
    train problem 1
    题目:
    Train Problem I
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 38224 Accepted Submission(s): 14372


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order


    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.


    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.


    题意:给你两串序列,问第二串能不能由第一个串在栈的进出操作中得到(第一个串进栈必须按照自己的顺序,出栈可以随时出)
    思路:直接模拟,注意判断条件


    Sample Input

    3 123 321
    3 123 312
    

    Sample Output

    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    

    Hint

    代码:

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<string>
    #include<iostream>
    #include<stack>
    using namespace std;
    
    string a,b;
    int c[11];
    int n,lena,lenb,aa,bb,cc;
    stack<char>s;
    
    int main()
    {
        while(scanf("%d",&n)!=EOF)
        {
            cin>>a>>b;
            while(!s.empty())
                s.pop();
            lena=a.length();
            lenb=b.length();
            aa=bb=cc=0;
            s.push(a[aa++]);
            c[cc++]=0;
            while(bb<lenb)
            {
                if(!s.empty()&&s.top()==b[bb])
                {
                    s.pop();
                    bb++;
                    c[cc++]=1;//out
                }
                else
                {
                    s.push(a[aa++]);
                    c[cc++]=0;//in
                }
            }
            if(s.empty())
            {
                printf("Yes.\n");
                for(int i=0;i<cc;i++)
                {
                    if(c[i]==1)
                        printf("out\n");
                    else
                        printf("in\n");
                }
            }
            else
            {
                printf("No.\n");
            }
            printf("FINISH\n");
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:STL hdu1022-Train Problem I

          本文链接:https://www.haomeiwen.com/subject/fercpxtx.html