一.题目
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
zigzag.jpgInput Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
二.题意
给出一个树的中序和后序遍历的结果,求它的Z字型层序遍历,也就是偶数层从右向左,奇数层从左到右遍历
三.代码部分
#include<bits/stdc++.h>
using namespace std;
vector<int> in,post,result[35];
int n,tree[35][2],root;
struct node{
int index,depth;//树的值与深度
};
void dfs(int &index, int inLeft, int inRight, int postLeft, int postRight) {//使用&的原因是index的值需要改变
if (inLeft > inRight) return;//dfs的循环跳出的条件
index = postRight;//当前根节点的下标
int i = 0;
while (in[i] != post[postRight]) i++;//寻找后序的根在中序遍历的位置
dfs(tree[index][0], inLeft, i - 1, postLeft, postLeft + (i - inLeft) - 1);//递归遍历左子树
dfs(tree[index][1], i + 1, inRight, postLeft + (i - inLeft), postRight - 1);//递归遍历右子树
}
void bfs(){//层序遍历
queue<node> q;
q.push(node{root,0});//根节点push进queue
while(!q.empty()){
node temp=q.front();
q.pop();
result[temp.depth].push_back(post[temp.index]);//增加depth的信息
if(tree[temp.index][0]!=0)//左子树
q.push(node{tree[temp.index][0],temp.depth+1});
if(tree[temp.index][1]!=0)//右子树
q.push(node{tree[temp.index][1],temp.depth+1});
}
}
int main() {
cin >> n;
in.resize(n + 1), post.resize(n + 1);//重新设置大小为n+1
for (int i = 1; i <= n; i++) cin >> in[i];//输入中序序列
for (int i = 1; i <= n; i++) cin >> post[i];//输入后序序列
dfs(root, 1, n, 1, n);//dfs进行遍历
bfs();//层序遍历,将信息添加到node中
printf("%d", result[0][0]);//首先输出根节点
for (int i = 1; i < 35; i++) {
if (i % 2 == 1) {//奇数层
for (int j = 0; j < result[i].size(); j++)
printf(" %d", result[i][j]);//逐个输出
} else {//偶数层
for (int j = result[i].size() - 1; j >= 0; j--)
printf(" %d", result[i][j]);//逐个输出
}
}
return 0;
}
网友评论