美文网首页
PAT 甲级 刷题日记|A 1030 Travel Plan (

PAT 甲级 刷题日记|A 1030 Travel Plan (

作者: 九除以三还是三哦 | 来源:发表于2021-08-22 09:19 被阅读0次

题目

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
结尾无空行

Sample Output:

0 2 3 3 40
结尾无空行

思路

这道题单纯的考察最短路径,涉及到路径打印,当两个路径长度一样时,选择花费少的,需要多一层判断。

代码

#include <bits/stdc++.h>
using namespace std;

int n, m, s, d;
const int maxn = 505;
const int inf = 1e9;
int gra[maxn][maxn];
int val[maxn][maxn];
int visit[maxn];
int dis[maxn];
int cost[maxn];
int pre[maxn];
vector<int> path;

int main() {
    fill(dis, dis + maxn, inf);
    fill(gra[0], gra[0] + maxn * maxn, inf);
    fill(val[0], val[0] + maxn * maxn, inf);
    cin>>n>>m>>s>>d;
    for (int i = 0; i < m; i++) {
        int a, b;
        cin>>a>>b;
        cin>>gra[a][b]>>val[a][b];
        gra[b][a] = gra[a][b];
        val[b][a] = val[a][b];
    }
    dis[s] = 0;
    cost[s] = 0;
    pre[s] = s;
    for (int i = 0; i < n; i ++) {
        int u = -1, mindis = inf;
        for (int j = 0; j < n; j++) {
            if (visit[j] == 0 && dis[j] < mindis) {
                u = j;
                mindis = dis[j];
            }
        }
        if (u == -1) break;
        visit[u] = 1;
        for (int v = 0; v < n; v++) {
            if (visit[v] == 0 && gra[u][v] != inf) {
                if (dis[v] > gra[u][v] + dis[u]) {
                    dis[v] = gra[u][v] + dis[u];
                    cost[v] = cost[u] + val[u][v];
                    pre[v] = u;
                } else if (dis[v] == gra[u][v] + dis[u]) {
                    if (cost[v] > cost[u] + val[u][v]) {
                        cost[v] = cost[u] + val[u][v];
                        pre[v] = u;
                    }
                }
            }
        }
        
    }
    int id = d;
    while (1) {
        path.push_back(pre[id]);
        id = pre[id];
        if (id == s) break;
    }
    for (int i = path.size() - 1; i >= 0; i--) {
        cout<<path[i]<<" ";
    }
    cout<<d<<" "<<dis[d]<<" "<<cost[d];
}

相关文章

网友评论

      本文标题:PAT 甲级 刷题日记|A 1030 Travel Plan (

      本文链接:https://www.haomeiwen.com/subject/fqyibltx.html