Identity Card
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4598 Accepted Submission(s): 1755
Problem Description
Do you own an ID card?You must have a identity card number in your family's Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.
image
However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel's ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
Sample Input
1
330000198910120036
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
Author
Samuel
Source
Recommend
zty | We have carefully selected several similar problems for you: 2626 2628 2630 2634 2632
AC代码:
#include<stdio.h>
#include "string"//不能直接#include "string.h"
#include "iostream"
using namespace std;
int main()
{
int n;
scanf("%d",&n);
string input_str,place;
for (int i=0;i<n;i++)
{
cin>>input_str;
if(input_str.substr(0,2)=="33")//字符串截取函数substr(i,n),其中i为起始位置,n为截取长度
place="Zhejiang";
else if(input_str.substr(0,2)=="11")
place="Beijing";
else if(input_str.substr(0,2)=="71")
place="Taiwan";
else if(input_str.substr(0,2)=="81")
place="Hong Kong";
else if(input_str.substr(0,2)=="82")
place="Macao";
else if(input_str.substr(0,2)=="54")
place="Tibet";
else if(input_str.substr(0,2)=="21")
place="Liaoning";
else if(input_str.substr(0,2)=="31")
place="Shanghai";
cout <<"He/She is from"<<" "<< place
<< ",and his/her birthday is on"<<" "<<input_str.substr(10,2)<<","
<<input_str.substr(12,2)<<","<<input_str.substr(6,4)<<" "
<<"based on the table."<<endl;
//printf("He/She is from %s,and his/her birthday is on %d%d,%d%d,%d%d%d%d based on the table.\n",place,input_str.substr(10,2),input_str.substr(12,2),input_str.substr(6,4));
}
}
网友评论