美文网首页
PAT乙级1095-Python

PAT乙级1095-Python

作者: 逆风飞翔的鸟 | 来源:发表于2019-03-23 08:46 被阅读0次

    1095 解码PAT准考证

    注意:该代码不是满分代码

    PAT 准考证号由 4 部分组成:

    • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
    • 第 2~4 位是考场编号,范围从 101 到 999;
    • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
    • 最后 11~13 位是考生编号,范围从 000 到 999。

    现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

    输入格式:

    输入首先在一行中给出两个正整数 N(≤10e​4)和 M(≤100),分别为考生人数和统计要求的个数。
    接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。
    考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

    • 类型为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的指令则给出代表指定级别的字母;
    • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的指令则给出指定考场的编号;
    • 类型为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的指令则给出指定日期,格式与准考证上日期相同。

    输出格式:

    对每项统计要求,首先在一行中输出Case #:要求,其中#是该项要求的编号,从 1 开始;要求即复制输入给出的要求。随后输出相应的统计结果:

    • 类型为 1 的指令,输出格式与输入的考生信息格式相同,即准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
    • 类型为 2 的指令,按人数 总分的格式输出;
    • 类型为 3 的指令,输出按人数非递增顺序,格式为考场编号 总人数。若人数并列则按考场编号递增顺序输出。
      如果查询结果为空,则输出NA

    输入样例

    8 4
    B123180908127 99
    B102180908003 86
    A112180318002 98
    T107150310127 62
    A107180908108 100
    T123180908010 78
    B112160918035 88
    A107180908021 98
    1 A
    2 107
    3 180908
    2 999
    

    输出样例

    Case 1: 1 A
    A107180908108 100
    A107180908021 98
    A112180318002 98
    Case 2: 2 107
    3 260
    Case 3: 3 180908
    107 2
    123 2
    102 1
    Case 4: 2 999
    NA
    

    代码

    from collections import Counter
    
    
    def caculateSumScore(classNum, studentList):
        sumScore = 0
        count = 0
        for i in range(len(studentList)):
            if classNum == studentList[i][0][1:4]:
                count = count + 1
                sumScore = sumScore + int(studentList[i][1])
        if count == 0:
            print('Case ' + str(caseNum) + ': ' + str(2) + ' ' + str(classNum))
            print("NA")
        else:
            print('Case ' + str(caseNum) + ': ' + str(2) + ' ' + str(classNum))
            print(str(count) + ' ' + str(sumScore))
    
    
    def sortGradeScores(testGrade, studentList):
        filterStudentList = []
        for i in range(len(studentList)):
            if testGrade == studentList[i][0][0]:
                filterStudentList.append(studentList[i])
        resultList = sorted(filterStudentList, key=lambda x: (x[1], x[0]))
        print('Case ' + str(caseNum) + ': ' + str(1) + ' ' + str(testGrade))
        for i in resultList:
            print(i[0] + ' ' + i[1])
    
    
    def sortDateLocations(date, studentList):
        filterStudentList = []
    
        for i in range(len(studentList)):
            if date == studentList[i][0][4:10]:
                filterStudentList.append(studentList[i][0][1:4])
        # print(Counter(filterStudentList).items())
        resultList = sorted(Counter(filterStudentList).items(), key=lambda x: x[1], reverse=True)
        resultList = sorted(resultList, key=lambda x: (-x[1], x[0]))
        print('Case ' + str(caseNum) + ': ' + str(3) + ' ' + str(date))
        for i in resultList:
            print(i[0] + ' ' + str(i[1]))
    
    
    def main():
        global caseNum
        caseNum = 1
        N, M = [int(x) for x in input().split(" ")]
        # 录入学生信息
        studentList = []
        for i in range(N):
            studentList.append(input().split())
        # 存储所有要执行的指令
        caseList = []
        for i in range(M):
            caseList.append(input().split())
        # 按照不同要求打印符合条件的情况
        for i in range(len(caseList)):
            if caseList[i][0] == '1':
                sortGradeScores(caseList[i][1], studentList)
            elif caseList[i][0] == '2':
                caculateSumScore(caseList[i][1], studentList)
            else:
                sortDateLocations(caseList[i][1], studentList)
            caseNum += 1
        # print(studentList)
        # print(caseList)
    
    
    if __name__ == "__main__":
        main()
    

    相关文章

      网友评论

          本文标题:PAT乙级1095-Python

          本文链接:https://www.haomeiwen.com/subject/guirvqtx.html