美文网首页
1058. Prime Factors

1058. Prime Factors

作者: Mapoos | 来源:发表于2018-02-16 12:24 被阅读0次

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意

给出一个int范围的整数,进行质因数分解,质因数按从小到大顺序排列。

思路

利用“筛法”求质因数的原理,按照质数从小到大的顺序(上限为sqrt(n)),依次去除n,直到无法除尽,则每次剩下的n只可能是其他质数的倍数;如果n无法被sqrt(n)以内的质因子除尽,则一定有且仅有一个大于sqrt(n)的质因子。

代码实现

#include <cstdio>
#include <cmath>

int facNum = 0;

struct factor
{
    int x, cnt;     // x存储质因子,cnt存储质因子个数
} fac[10];      // 对于int范围整数,最多有10个不同的质因子

void Create_Fac(int n)
{
    int num;        // num记录当前质因子个数
    for (int i = 2; i <= sqrt(n); i++)
    {
        num = 0;
        while (n % i == 0)
        {
            n /= i;
            num++;
        }
        if (num)        // 质因子个数大于0则记录到数组中
        {
            fac[facNum].x = i;
            fac[facNum].cnt = num;
            facNum++;
        }
    }
    if (n > 1)      // 如果无法被sqrt(n)以内的质因子除尽,则一定有一个大于sqrt(n)的质因子
    {
        fac[facNum].x = n;
        fac[facNum].cnt = 1;
        facNum++;
    }
}

void Print_Fac(int n)
{
    if (n == 0 || n == 1)       // 对于特殊情况的处理
    {
        printf("%d=%d", n, n);
        return;
    }
    printf("%d=", n);
    for (int i = 0; i < facNum; i++)
    {
        if (i > 0)
            printf("*");
        printf("%d", fac[i].x);
        if (fac[i].cnt > 1)
            printf("^%d", fac[i].cnt);
    }
}

int main()
{
    int n;
    scanf("%d", &n);
    Create_Fac(n);
    Print_Fac(n);
    return 0;
}

相关文章

网友评论

      本文标题:1058. Prime Factors

      本文链接:https://www.haomeiwen.com/subject/hakptftx.html