美文网首页
PAT 甲级 刷题日记|A 1094 The Largest

PAT 甲级 刷题日记|A 1094 The Largest

作者: 九除以三还是三哦 | 来源:发表于2021-08-27 18:37 被阅读0次

    A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

    Input Specification:

    Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

    ID K ID[1] ID[2] ... ID[K]
    

    where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

    Sample Input:

    23 13
    21 1 23
    01 4 03 02 04 05
    03 3 06 07 08
    06 2 12 13
    13 1 21
    08 2 15 16
    02 2 09 10
    11 2 19 20
    17 1 22
    05 1 11
    07 1 14
    09 1 17
    10 1 18结尾无空行
    

    Sample Output:

    9 4结尾无空行
    

    思路

    这道题和1004非常相似, 一般树的遍历。信息多时用结构体存,只有子节点是vector数组即可。

    代码

    #include <bits/stdc++.h>
    using namespace std;
    
    const int maxn = 105;
    vector<int> tree[maxn];
    int cnt[maxn];
    int maxid = 0, maxnum = 0;
    int n, m;
    
    void dfs (int root, int level) {
        cnt[level]++;
        if (maxnum < cnt[level]) {
            maxnum = cnt[level];
            maxid = level;
        }
        for (int i = 0; i < tree[root].size(); i++) {
            dfs(tree[root][i], level + 1);
        }
    }
    
    int main() {
        cin>>n>>m;
        for (int i = 0; i < m; i++) {
            int a, len;
            cin>>a>>len;
            for (int j = 0; j < len; j++) {
                int num;
                cin>>num;
                tree[a].push_back(num);
            }
        }
        dfs(1, 1);
        cout<<maxnum<<" "<<maxid<<endl;
    }
    
    

    相关文章

      网友评论

          本文标题:PAT 甲级 刷题日记|A 1094 The Largest

          本文链接:https://www.haomeiwen.com/subject/hgggbltx.html