美文网首页
2020-04-10

2020-04-10

作者: joker_luo | 来源:发表于2020-04-10 21:20 被阅读0次

1062 Talent and Virtue (25分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

      
    

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

      
    

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct node{
    int id;
    int t;
    int v;
}node;
vector<node> person[4];
int m,l,h;
int cmp(node a,node b){
    if((a.t + a.v) != (b.t + b.v)){
        return (a.t + a.v) > (b.t + b.v);
    }else if(a.v != b.v){
        return a.v > b.v;
    }else{
        return a.id < b.id;
    }
}
int main(){
    scanf("%d %d %d",&m,&l,&h);
    node a;
    int total = m;
    for(int i=0;i<m;++i){
        scanf("%d %d %d",&a.id,&a.v,&a.t);
        if(a.t<l || a.v<l){
            total--;
        }
        //圣人 
        else if(a.t>=h&& a.v>=h){
            person[0].push_back(a);
        }
        //君子    
        else if(a.v>=h && a.t<h){
            person[1].push_back(a);
        }
        //愚人 
        else if(a.v < h && a.t < h && a.v >= a.t){
            person[2].push_back(a);
        }
        else{
            person[3].push_back(a);
        }
    }
    cout<<total<<endl;
    for(int i=0;i<4;++i){
        sort(person[i].begin(),person[i].end(),cmp);
        for(int j=0;j<person[i].size();j++){
            printf("%d %d %d\n",person[i][j].id,person[i][j].v,person[i][j].t);
        }
    }
    return 0;
}

相关文章

  • 正则

    日期日期格式通常为:2020-04-10,2020-04-10 10:35:52,2020/04/40,2020/...

  • HP Pavilion Gaming 15-ak004TX 黑苹

    安装日期:2020-04-10 安装镜像: macOS Catalina 10.15.4(19E266) 链接: ...

  • 晚间日记2

    今天2020-04-10 起床:07:00 就寝:24:00 天气:阴天 心情:不错呀 任务清单 今天完成的任务,...

  • 《贫穷的本质》1

    Day25 2020-04-10 《贫穷的本质》第1-5章 【字数】 读了,看了,思考了,越觉得贫穷的本质种种原因...

  • 命自我立,福自我求NO.146

    2020-04-10 星期五 晴 事在人为,命自我立,任何人的命运,归根结底都是自己创造的。在命运面前...

  • 《虎面》:迷幻而又纯真的小镇记忆

    作者:何凯凯(2020-04-10《文艺报》) 2020年1月,“90后”陕西作家范墩子出版了他的新书《虎面》。该...

  • 梅梅的声音训练之路……

    2020-04-10 10:15 我是子涵声音私房课第19期学员梅梅,28天,我收获了幸会、幸运和幸福! 在加入私...

  • 学历真是个打不破的魔咒/浮躁

    2020-04-10 看到的一条,微博的热搜就是学历对找工作的影响。 于是可能今天自身关注的就是这些。评论有提到学...

  • 大黑的“乌鸡汤” 1. 怎么过好这一生

    来自专栏:美白乌鸡汤 共15篇 怎么过好这一生 2020-04-10 阅读 48万+ 这一篇算是综合性地和大家分享...

  • 2020-04-10 野心

    2020-04-10 野心 目前的工作,不是太理想。 首先是从事的工作内容过于枯燥和单调,一天天对着电脑整理一些产...

网友评论

      本文标题:2020-04-10

      本文链接:https://www.haomeiwen.com/subject/hzqjmhtx.html