美文网首页
1042 字符统计 (20分)(Python)

1042 字符统计 (20分)(Python)

作者: 爱折腾的程序猿 | 来源:发表于2020-05-29 17:21 被阅读0次

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

代码实现:

word = [x for x in input().replace(' ','').lower() if x.islower()]
result = {}
for item in set(word):
    result[item] = word.count(item)
result = sorted(result.items(),key=lambda x:x[1],reverse=True)
temp = [result[0]]
for item in result[1:]:
    if result[0][1] == item[1]:
        temp.append(item)
    else:
        break
temp.sort(key=lambda x:x[0])
print(temp[0][0] + ' '+str(temp[0][1]))

相关文章

网友评论

      本文标题:1042 字符统计 (20分)(Python)

      本文链接:https://www.haomeiwen.com/subject/jdxgahtx.html