美文网首页
ACM 之 M - 基础DP

ACM 之 M - 基础DP

作者: Gadore千里 | 来源:发表于2016-08-12 18:40 被阅读23次

    Description

    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

    Input

    The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

    Output

    One integer per line representing the maximum of the total value (this number will be less than 2 ^31).

    Sample Input

    1
    5 10
    1 2 3 4 5
    5 4 3 2 1

    Sample Output

    14

    理解:

    第一道DP题,也就是01背包问题,我的做法就是多看多写多理解。
    另外,个人感觉用一位数组更简洁明了。

    代码部分

    #include <cstdio>
    #include <cstring>
    using namespace std;
    int va[101],vo[101],dp[100002],t,n,v;
    inline int Max(int x,int y)
    {return x>y?x:y;}
    int main()
    {
        while(scanf("%d",&t)!=EOF)
        {
            getchar();
            for(int i=0;i<t;i++)
            {
                scanf("%d%d",&va[i],&vo[i]);
            }getchar();
            scanf("%d",&v);getchar();
            memset(dp,0,sizeof(dp));
            for(int i=0;i<t;i++)
                for(int j=vo[i];j<=v;j++)
                    dp[j]=Max(dp[j],dp[j-vo[i]]+va[i]);
            printf("%d\n",dp[v]);
        }
        return 0;
    }
    

    意见反馈 || 任何建议

    联系我(新浪)
    邮箱:qianlizhihao@gmail.com

    相关文章

      网友评论

          本文标题:ACM 之 M - 基础DP

          本文链接:https://www.haomeiwen.com/subject/khdesttx.html