美文网首页
PAT Advanced 1035. Password (20)

PAT Advanced 1035. Password (20)

作者: OliverLew | 来源:发表于2020-04-29 00:09 被阅读0次

    我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

    题目

    To prepare for PAT, the judge sometimes has to generate random passwords for
    the users. The problem is that there are always some confusing passwords since
    it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero)
    from O (o in uppercase). One solution is to replace 1 (one) by @, 0
    (zero) by %, l by L, and O by o. Now it is your job to write a
    program to check the accounts generated by the judge, and to help the juge
    modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer
    N ( \le 1000 ), followed by N lines of accounts. Each account consists
    of a user name and a password, both are strings of no more than 10 characters
    with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been
    modified, then print in the following M lines the modified accounts info,
    that is, the user names and the corresponding modified passwords. The accounts
    must be printed in the same order as they are read in. If no account is
    modified, print in one line There are N accounts and no account is modified
    where N is the total number of accounts. However, if N is one, you must
    print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified
    

    思路

    将密码中的几个字符转化为另一个字符,很简单的题目。

    我的具体做法是边读边改,并且将无需更改的密码首字符置为'\0',就是当做标记以便区分。后面输出就容易了。

    代码

    最新代码@github,欢迎交流

    #include <stdio.h>
    
    int main()
    {
        int N, count = 0, modified;
        char username[1000][11], password[1000][11];
    
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
        {
            modified = 0;
            scanf("%s %s", username[i], password[i]);
            for(char *p = password[i]; *p; p++)
            {
                switch(*p)
                {
                    case '1': *p = '@'; modified = 1; break;
                    case '0': *p = '%'; modified = 1; break;
                    case 'l': *p = 'L'; modified = 1; break;
                    case 'O': *p = 'o'; modified = 1; break;
                    default: break;
                }
            }
            if(modified)
                count++;
            else  /* mark unmodified password */
                password[i][0] = '\0';
        }
    
        if(count)
        {
            printf("%d\n", count);
            for(int i = 0; i < N; i++)
                if(password[i][0] != '\0')
                    printf("%s %s\n", username[i], password[i]);
        }
        else
        {
            printf("There %s %d %s and no account is modified",
                N > 1 ? "are" : "is", N, N > 1 ? "accounts" : "account");
        }
    
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT Advanced 1035. Password (20)

          本文链接:https://www.haomeiwen.com/subject/kyhwwhtx.html