美文网首页
【PAT-甲级-C++】1003. Emergency (25)

【PAT-甲级-C++】1003. Emergency (25)

作者: linghugoogle | 来源:发表于2018-01-22 23:42 被阅读40次

    1003. Emergency (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input
    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    Sample Output
    2 4
    

    2、说明

    1)使用DFS即可;
    2)注意有向图、无向图;
    3)最大最小值判断的位置;
    4)全局变量的命名最好不要烂大街。

    3、代码

    #include<iostream>
    #include<cstdio>
    #define MAX 10000
    #define NUM 600
    using namespace std;
    int book[NUM] = { 0 };      //标记
    int map[NUM][NUM];          //连接
    int n, dis_min=MAX;         //城市数量、最短距离
    int weight[NUM];            //节点权重
    int cnt = 0;                //最小路径数量
    int dend;                   //终点
    int max_weight=0;           //最大节点权重和
    void dfs(int cur, int dis, int wei) {
        int i;
        //剪枝
        if (dis > dis_min)
            return;
        //判断终点
        if (cur == dend) {
            if (dis < dis_min) {
                dis_min = dis;
                cnt = 1;
                max_weight = wei;
            }
            else if (dis == dis_min) {
                cnt++;
                if (wei > max_weight)
                    max_weight = wei;
            }
            return;
        }
        //继续下一层
        for (i = 0;i < n;++i) {
            if (map[cur][i] != MAX&&book[i] == 0) {
                book[i] = 1;
                dfs(i, dis+ map[cur][i], wei+weight[i]);
                book[i] = 0;
            }
        }
        return;
    }
    int main() {
        int m;
        int dbegin;
        cin >> n >> m >> dbegin >> dend;
        
        //map初始化
        int i, j;
        int beg, end, wei;
        for (i = 0;i < n;++i) {
            for (j = 0;j < n;++j) {
                if (i == j)
                    map[i][j] = 0;
                else
                    map[i][j] = MAX;
            }
        }
        //读入权重
        for (i = 0;i < n;++i) {
            cin >> weight[i];
        }
        //读入路径
        //无向图
        for (i = 0;i < m;++i) {
            scanf("%d %d %d", &beg, &end, &wei);
            map[beg][end] = wei;
            //有向图注释掉下面一句
            map[end][beg] = wei;
        }
        //深度优先遍历
        book[dbegin] = 1;
        dfs(dbegin, 0,weight[dbegin]);
        cout << cnt<<" "<<max_weight;
        system("pause");
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:【PAT-甲级-C++】1003. Emergency (25)

          本文链接:https://www.haomeiwen.com/subject/lofdaxtx.html