题目信息
1003 Emergency (25)(25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.\ All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
代码
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
int n,m,c1,c2,a,b,c;const int inf=99999999;//n个city,m条road,找c1到c2的最短路径。a,b,c为temp
int e[502][502],weight[502],dis[502],num[502],w[502];
bool visit[502];
scanf("%d%d%d%d",&n,&m,&c1,&c2);
for(int i=0;i<n;i++) scanf("%d",&weight[i]);//每个结点的权重,这里为每个city的救援队数量
fill(e[0],e[0]+502*502,inf);
fill(dis,dis+502,inf);
for(int i=0;i<m;i++){
scanf("%d%d%d",&a,&b,&c);e[a][b]=e[b][a]=c;//题意为无向图 ,初始化
}
dis[c1]=0,w[c1]=weight[c1],num[c1]=1;
for(int i=0;i<n;i++){ //每次找出c1到其距离最短的点u,收入,置已访问
int u=-1,minn=inf;
for(int j=0;j<n;j++){
if(visit[j]==false&&dis[j]<minn){
u=j;minn=dis[j];//更新最近结点和最近距离
}
}
if(u==-1) break;
visit[u]=true;
for(int v=0;v<n;v++){//收入新结点u后,更新所有相关信息
if(visit[v]==false&&e[u][v]!=inf){
if(dis[u]+e[u][v]<dis[v]){
dis[v]=dis[u]+e[u][v];
num[v]=num[u];
w[v]=w[u]+weight[v];
}else if(dis[u]+e[u][v]==dis[v]){
num[v]=num[v]+num[u];
if(w[u]+weight[v]>w[v]) w[v]=w[u]+weight[v];
}
}
}
}
printf("%d %d",num[c2],w[c2]);
return 0;
}
测试结果
![](https://img.haomeiwen.com/i12536835/f84e30c36bf9bf25.png)
网友评论