PAT甲级1006

作者: minibanana丶 | 来源:发表于2020-04-02 10:11 被阅读0次

    1006 Sign In and Sign Out (25分)
    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:
    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
    ID_number Sign_in_time Sign_out_time
    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:
    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40

    Sample Output:
    SC3021234 CS301133

    #include <iostream>
    using namespace std;
    int main(){
        int n;
        cin >> n;
        string id, open, close;
        string open_id, open_time;
        string close_id, close_time;
        for (int i = 0; i < n; i++){
            cin >> id >> open >> close;
            //利用字典序比较
            if (!i || open_time > open){
                open_time = open;
                open_id = id;
            }
            if (!i || close_time < close){
                close_time = close;
                close_id = id;
            }
        }
        cout << open_id << " " << close_id << endl;
        return 0;
    }
    

    这题是考查字符串的处理,这是一个签到签出的问题。每个人都会签到签出,第一个签到的人开门,最后一个签出的人关门,输出这两个人的id。这道题的难点在于比较时间的大小,仔细观察会发现这题的时间是很有规律的,都是hh:mm:ss这样子的,所以可以用字典序来直接比较,这样子这题是非常简单了。

    相关文章

      网友评论

        本文标题:PAT甲级1006

        本文链接:https://www.haomeiwen.com/subject/lvvtphtx.html