1. 前言
我们在日常使用中除了可以通过 ps
命令可以查询到操作系统中所有的进程之外,使用最多的另外一种方式就是 lsof
命令。
lsof
命令, list opened files
的缩写,列举操作系统中已经被打开的文件。通过 lsof
命令,我们就可以根据文件找到对应的进程信息,也可以根据进程信息找到进程打开的文件。
话外之音 Linux 操作系统中,一切皆文件
2. 常用操作
选项 | 功能 |
---|---|
-i: ${port} | 列出某个 端口 进程信息 |
-p ${pid} | 列出某个 PID 进程信息 |
-c ${name} | 列出 名字开头的 进程信息 |
+d ${path} | 列出该文件夹下文件 |
-u ${user} | 列出该用户下所有进程信息 |
3. man
LSOF(8) System Manager's Manual LSOF(8)
NAME
lsof - list open files
SYNOPSIS
lsof [ -?abChKlnNOPRtUvVX ] [ -A A ] [ -c c ] [ +c c ] [ +|-d d ] [ +|-D D ] [ +|-e s ] [ +|-f [cfgGn] ] [ -F [f] ] [
-g [s] ] [ -i [i] ] [ -k k ] [ +|-L [l] ] [ +|-m m ] [ +|-M ] [ -o [o] ] [ -p s ] [ +|-r [t[m<fmt>]] ] [ -s [p:s] ] [
-S [t] ] [ -T [t] ] [ -u s ] [ +|-w ] [ -x [fl] ] [ -z [z] ] [ -Z [Z] ] [ -- ] [names]
DESCRIPTION
Lsof revision 4.87 lists on its standard output file information about files opened by processes for the following
UNIX dialects:
Apple Darwin 9 and Mac OS X 10.[567]
FreeBSD 4.9 and 6.4 for x86-based systems
FreeBSD 8.2, 9.0 and 10.0 for AMD64-based systems
Linux 2.1.72 and above for x86-based systems
Solaris 9, 10 and 11
(See the DISTRIBUTION section of this manual page for information on how to obtain the latest lsof revision.)
An open file may be a regular file, a directory, a block special file, a character special file, an executing text
reference, a library, a stream or a network file (Internet socket, NFS file or UNIX domain socket.) A specific file
or all the files in a file system may be selected by path.
Instead of a formatted display, lsof will produce output that can be parsed by other programs. See the -F, option
description, and the OUTPUT FOR OTHER PROGRAMS section for more information.
In addition to producing a single output list, lsof will run in repeat mode. In repeat mode it will produce output,
delay, then repeat the output operation until stopped with an interrupt or quit signal. See the +|-r [t[m<fmt>]]
option description for more information.
OPTIONS
In the absence of any options, lsof lists all open files belonging to all active processes.
If any list request option is specified, other list requests must be specifically requested - e.g., if -U is speci‐
fied for the listing of UNIX socket files, NFS files won't be listed unless -N is also specified; or if a user list
is specified with the -u option, UNIX domain socket files, belonging to users not in the list, won't be listed unless
the -U option is also specified.
Normally list options that are specifically stated are ORed - i.e., specifying the -i option without an address and
the -ufoo option produces a listing of all network files OR files belonging to processes owned by user ``foo''. The
exceptions are:
1) the `^' (negated) login name or user ID (UID), specified with the -u option;
2) the `^' (negated) process ID (PID), specified with the -p option;
3) the `^' (negated) process group ID (PGID), specified with the -g option;
4) the `^' (negated) command, specified with the -c option;
5) the (`^') negated TCP or UDP protocol state names, specified with the -s [p:s] option.
Since they represent exclusions, they are applied without ORing or ANDing and take effect before any other selection
criteria are applied.
The -a option may be used to AND the selections. For example, specifying -a, -U, and -ufoo produces a listing of
only UNIX socket files that belong to processes owned by user ``foo''.
Caution: the -a option causes all list selection options to be ANDed; it can't be used to cause ANDing of selected
pairs of selection options by placing it between them, even though its placement there is acceptable. Wherever -a is
placed, it causes the ANDing of all selection options.
Items of the same selection set - command names, file descriptors, network addresses, process identifiers, user iden‐
tifiers, zone names, security contexts - are joined in a single ORed set and applied before the result participates
in ANDing. Thus, for example, specifying -i@aaa.bbb, -i@ccc.ddd, -a, and -ufff,ggg will select the listing of files
that belong to either login ``fff'' OR ``ggg'' AND have network connections to either host aaa.bbb OR ccc.ddd.
Options may be grouped together following a single prefix -- e.g., the option set ``-a -b -C'' may be stated as -abC.
However, since values are optional following +|-f, -F, -g, -i, +|-L, -o, +|-r, -s, -S, -T, -x and -z. when you have
no values for them be careful that the following character isn't ambiguous. For example, -Fn might represent the -F
and -n options, or it might represent the n field identifier character following the -F option. When ambiguity is
possible, start a new option with a `-' character - e.g., ``-F -n''. If the next option is a file name, follow the
possibly ambiguous option with ``--'' - e.g., ``-F -- name''.
Either the `+' or the `-' prefix may be applied to a group of options. Options that don't take on separate meanings
for each prefix - e.g., -i - may be grouped under either prefix. Thus, for example, ``+M -i'' may be stated as
``+Mi'' and the group means the same as the separate options. Be careful of prefix grouping when one or more options
in the group does take on separate meanings under different prefixes - e.g., +|-M; ``-iM'' is not the same request as
``-i +M''. When in doubt, use separate options with appropriate prefixes.
-? -h These two equivalent options select a usage (help) output list. Lsof displays a shortened form of this out‐
put when it detects an error in the options supplied to it, after it has displayed messages explaining each
error. (Escape the `?' character as your shell requires.)
-a causes list selection options to be ANDed, as described above.
-A A is available on systems configured for AFS whose AFS kernel code is implemented via dynamic modules. It
allows the lsof user to specify A as an alternate name list file where the kernel addresses of the dynamic
modules might be found. See the lsof FAQ (The FAQ section gives its location.) for more information about
dynamic modules, their symbols, and how they affect lsof.
-b causes lsof to avoid kernel functions that might block - lstat(2), readlink(2), and stat(2).
See the BLOCKS AND TIMEOUTS and AVOIDING KERNEL BLOCKS sections for information on using this option.
-c c selects the listing of files for processes executing the command that begins with the characters of c. Mul‐
tiple commands may be specified, using multiple -c options. They are joined in a single ORed set before
participating in AND option selection.
If c begins with a `^', then the following characters specify a command name whose processes are to be
ignored (excluded.)
If c begins and ends with a slash ('/'), the characters between the slashes are interpreted as a regular
expression. Shell meta-characters in the regular expression must be quoted to prevent their interpretation
by the shell. The closing slash may be followed by these modifiers:
b the regular expression is a basic one.
i ignore the case of letters.
x the regular expression is an extended one
(default).
See the lsof FAQ (The FAQ section gives its location.) for more information on basic and extended regular
expressions.
The simple command specification is tested first. If that test fails, the command regular expression is
applied. If the simple command test succeeds, the command regular expression test isn't made. This may
result in ``no command found for regex:'' messages when lsof's -V option is specified.
+c w defines the maximum number of initial characters of the name, supplied by the UNIX dialect, of the UNIX com‐
mand associated with a process to be printed in the COMMAND column. (The lsof default is nine.)
Note that many UNIX dialects do not supply all command name characters to lsof in the files and structures
from which lsof obtains command name. Often dialects limit the number of characters supplied in those
sources. For example, Linux 2.4.27 and Solaris 9 both limit command name length to 16 characters.
If w is zero ('0'), all command characters supplied to lsof by the UNIX dialect will be printed.
If w is less than the length of the column title, ``COMMAND'', it will be raised to that length.
-C disables the reporting of any path name components from the kernel's name cache. See the KERNEL NAME CACHE
section for more information.
+d s causes lsof to search for all open instances of directory s and the files and directories it contains at its
top level. +d does NOT descend the directory tree, rooted at s. The +D D option may be used to request a
full-descent directory tree search, rooted at directory D.
Processing of the +d option does not follow symbolic links within s unless the -x or -x l option is also
specified. Nor does it search for open files on file system mount points on subdirectories of s unless the
-x or -x f option is also specified.
Note: the authority of the user of this option limits it to searching for files that the user has permission
to examine with the system stat(2) function.
-d s specifies a list of file descriptors (FDs) to exclude from or include in the output listing. The file
descriptors are specified in the comma-separated set s - e.g., ``cwd,1,3'', ``^6,^2''. (There should be no
spaces in the set.)
The list is an exclusion list if all entries of the set begin with `^'. It is an inclusion list if no entry
begins with `^'. Mixed lists are not permitted.
A file descriptor number range may be in the set as long as neither member is empty, both members are num‐
bers, and the ending member is larger than the starting one - e.g., ``0-7'' or ``3-10''. Ranges may be
specified for exclusion if they have the `^' prefix - e.g., ``^0-7'' excludes all file descriptors 0 through
7.
Multiple file descriptor numbers are joined in a single ORed set before participating in AND option selec‐
tion.
When there are exclusion and inclusion members in the set, lsof reports them as errors and exits with a
non-zero return code.
See the description of File Descriptor (FD) output values in the OUTPUT section for more information on file
descriptor names.
+D D causes lsof to search for all open instances of directory D and all the files and directories it contains to
its complete depth.
Processing of the +D option does not follow symbolic links within D unless the -x or -x l option is also
specified. Nor does it search for open files on file system mount points on subdirectories of D unless the
-x or -x f option is also specified.
Note: the authority of the user of this option limits it to searching for files that the user has permission
to examine with the system stat(2) function.
Further note: lsof may process this option slowly and require a large amount of dynamic memory to do it.
This is because it must descend the entire directory tree, rooted at D, calling stat(2) for each file and
directory, building a list of all the files it finds, and searching that list for a match with every open
file. When directory D is large, these steps can take a long time, so use this option prudently.
-D D directs lsof's use of the device cache file. The use of this option is sometimes restricted. See the
DEVICE CACHE FILE section and the sections that follow it for more information on this option.
-D must be followed by a function letter; the function letter may optionally be followed by a path name.
Lsof recognizes these function letters:
? - report device cache file paths
b - build the device cache file
i - ignore the device cache file
r - read the device cache file
u - read and update the device cache file
The b, r, and u functions, accompanied by a path name, are sometimes restricted. When these functions are
restricted, they will not appear in the description of the -D option that accompanies -h or -? option out‐
put. See the DEVICE CACHE FILE section and the sections that follow it for more information on these func‐
tions and when they're restricted.
The ? function reports the read-only and write paths that lsof can use for the device cache file, the names
of any environment variables whose values lsof will examine when forming the device cache file path, and the
format for the personal device cache file path. (Escape the `?' character as your shell requires.)
When available, the b, r, and u functions may be followed by the device cache file's path. The standard
default is .lsof_hostname in the home directory of the real user ID that executes lsof, but this could have
been changed when lsof was configured and compiled. (The output of the -h and -? options show the current
default prefix - e.g., ``.lsof''.) The suffix, hostname, is the first component of the host's name returned
by gethostname(2).
When available, the b function directs lsof to build a new device cache file at the default or specified
path.
The i function directs lsof to ignore the default device cache file and obtain its information about devices
via direct calls to the kernel.
The r function directs lsof to read the device cache at the default or specified path, but prevents it from
creating a new device cache file when none exists or the existing one is improperly structured. The r func‐
tion, when specified without a path name, prevents lsof from updating an incorrect or outdated device cache
file, or creating a new one in its place. The r function is always available when it is specified without a
path name argument; it may be restricted by the permissions of the lsof process.
When available, the u function directs lsof to read the device cache file at the default or specified path,
if possible, and to rebuild it, if necessary. This is the default device cache file function when no -D
option has been specified.
+|-e s exempts the file system whose path name is s from being subjected to kernel function calls that might block.
The +e option exempts stat(2), lstat(2) and most readlink(2) kernel function calls. The -e option exempts
only stat(2) and lstat(2) kernel function calls. Multiple file systems may be specified with separate +|-e
specifications and each may have readlink(2) calls exempted or not.
This option is currently implemented only for Linux.
CAUTION: this option can easily be mis-applied to other than the file system of interest, because it uses
path name rather than the more reliable device and inode numbers. (Device and inode numbers are acquired
via the potentially blocking stat(2) kernel call and are thus not available, but see the +|-m m option as a
possible alternative way to supply device numbers.) Use this option with great care and fully specify the
path name of the file system to be exempted.
When open files on exempted file systems are reported, it may not be possible to obtain all their informa‐
tion. Therefore, some information columns will be blank, the characters ``UNKN'' preface the values in the
TYPE column, and the applicable exemption option is added in parentheses to the end of the NAME column.
(Some device number information might be made available via the +|-m m option.)
+|-f [cfgGn]
f by itself clarifies how path name arguments are to be interpreted. When followed by c, f, g, G, or n in
any combination it specifies that the listing of kernel file structure information is to be enabled (`+') or
inhibited (`-').
Normally a path name argument is taken to be a file system name if it matches a mounted-on directory name
reported by mount(8), or if it represents a block device, named in the mount output and associated with a
mounted directory name. When +f is specified, all path name arguments will be taken to be file system
names, and lsof will complain if any are not. This can be useful, for example, when the file system name
(mounted-on device) isn't a block device. This happens for some CD-ROM file systems.
When -f is specified by itself, all path name arguments will be taken to be simple files. Thus, for exam‐
ple, the ``-f -- /'' arguments direct lsof to search for open files with a `/' path name, not all open files
in the `/' (root) file system.
Be careful to make sure +f and -f are properly terminated and aren't followed by a character (e.g., of the
file or file system name) that might be taken as a parameter. For example, use ``--'' after +f and -f as in
these examples.
$ lsof +f -- /file/system/name
$ lsof -f -- /file/name
The listing of information from kernel file structures, requested with the +f [cfgGn] option form, is nor‐
mally inhibited, and is not available in whole or part for some dialects - e.g., /proc-based Linux kernels
below 2.6.22. When the prefix to f is a plus sign (`+'), these characters request file structure informa‐
tion:
c file structure use count (not Linux)
f file structure address (not Linux)
g file flag abbreviations (Linux 2.6.22 and up)
G file flags in hexadecimal (Linux 2.6.22 and up)
n file structure node address (not Linux)
When the prefix is minus (`-') the same characters disable the listing of the indicated values.
File structure addresses, use counts, flags, and node addresses may be used to detect more readily identical
files inherited by child processes and identical files in use by different processes. Lsof column output
can be sorted by output columns holding the values and listed to identify identical file use, or lsof field
output can be parsed by an AWK or Perl post-filter script, or by a C program.
-F f specifies a character list, f, that selects the fields to be output for processing by another program, and
the character that terminates each output field. Each field to be output is specified with a single charac‐
ter in f. The field terminator defaults to NL, but may be changed to NUL (000). See the OUTPUT FOR OTHER
PROGRAMS section for a description of the field identification characters and the field output process.
When the field selection character list is empty, all standard fields are selected (except the raw device
field, security context and zone field for compatibility reasons) and the NL field terminator is used.
When the field selection character list contains only a zero (`0'), all fields are selected (except the raw
device field for compatibility reasons) and the NUL terminator character is used.
Other combinations of fields and their associated field terminator character must be set with explicit
entries in f, as described in the OUTPUT FOR OTHER PROGRAMS section.
When a field selection character identifies an item lsof does not normally list - e.g., PPID, selected with
-R - specification of the field character - e.g., ``-FR'' - also selects the listing of the item.
When the field selection character list contains the single character `?', lsof will display a help list of
the field identification characters. (Escape the `?' character as your shell requires.)
-g [s] excludes or selects the listing of files for the processes whose optional process group IDentification
(PGID) numbers are in the comma-separated set s - e.g., ``123'' or ``123,^456''. (There should be no spaces
in the set.)
PGID numbers that begin with `^' (negation) represent exclusions.
Multiple PGID numbers are joined in a single ORed set before participating in AND option selection. How‐
ever, PGID exclusions are applied without ORing or ANDing and take effect before other selection criteria
are applied.
The -g option also enables the output display of PGID numbers. When specified without a PGID set that's all
it does.
-i [i] selects the listing of files any of whose Internet address matches the address specified in i. If no
address is specified, this option selects the listing of all Internet and x.25 (HP-UX) network files.
If -i4 or -i6 is specified with no following address, only files of the indicated IP version, IPv4 or IPv6,
are displayed. (An IPv6 specification may be used only if the dialects supports IPv6, as indicated by
``[46]'' and ``IPv[46]'' in lsof's -h or -? output.) Sequentially specifying -i4, followed by -i6 is the
same as specifying -i, and vice-versa. Specifying -i4, or -i6 after -i is the same as specifying -i4 or -i6
by itself.
Multiple addresses (up to a limit of 100) may be specified with multiple -i options. (A port number or ser‐
vice name range is counted as one address.) They are joined in a single ORed set before participating in
AND option selection.
An Internet address is specified in the form (Items in square brackets are optional.):
[46][protocol][@hostname|hostaddr][:service|port]
where:
46 specifies the IP version, IPv4 or IPv6
that applies to the following address.
'6' may be be specified only if the UNIX
dialect supports IPv6. If neither '4' nor
'6' is specified, the following address
applies to all IP versions.
protocol is a protocol name - TCP, UDP
hostname is an Internet host name. Unless a
specific IP version is specified, open
network files associated with host names
of all versions will be selected.
hostaddr is a numeric Internet IPv4 address in
dot form; or an IPv6 numeric address in
colon form, enclosed in brackets, if the
UNIX dialect supports IPv6. When an IP
version is selected, only its numeric
addresses may be specified.
service is an /etc/services name - e.g., smtp -
or a list of them.
port is a port number, or a list of them.
IPv6 options may be used only if the UNIX dialect supports IPv6. To see if the dialect supports IPv6, run
lsof and specify the -h or -? (help) option. If the displayed description of the -i option contains
``[46]'' and ``IPv[46]'', IPv6 is supported.
IPv4 host names and addresses may not be specified if network file selection is limited to IPv6 with -i 6.
IPv6 host names and addresses may not be specified if network file selection is limited to IPv4 with -i 4.
When an open IPv4 network file's address is mapped in an IPv6 address, the open file's type will be IPv6,
not IPv4, and its display will be selected by '6', not '4'.
At least one address component - 4, 6, protocol, hostname, hostaddr, or service - must be supplied. The `@'
character, leading the host specification, is always required; as is the `:', leading the port specifica‐
tion. Specify either hostname or hostaddr. Specify either service name list or port number list. If a
service name list is specified, the protocol may also need to be specified if the TCP, UDP and UDPLITE port
numbers for the service name are different. Use any case - lower or upper - for protocol.
Service names and port numbers may be combined in a list whose entries are separated by commas and whose
numeric range entries are separated by minus signs. There may be no embedded spaces, and all service names
must belong to the specified protocol. Since service names may contain embedded minus signs, the starting
entry of a range can't be a service name; it can be a port number, however.
Here are some sample addresses:
-i6 - IPv6 only
TCP:25 - TCP and port 25
@1.2.3.4 - Internet IPv4 host address 1.2.3.4
@[3ffe:1ebc::1]:1234 - Internet IPv6 host address
3ffe:1ebc::1, port 1234
UDP:who - UDP who service port
TCP@lsof.itap:513 - TCP, port 513 and host name lsof.itap
tcp@foo:1-10,smtp,99 - TCP, ports 1 through 10,
service name smtp, port 99, host name foo
tcp@bar:1-smtp - TCP, ports 1 through smtp, host bar
:time - either TCP, UDP or UDPLITE time service port
-K selects the listing of tasks (threads) of processes, on dialects where task (thread) reporting is supported.
(If help output - i.e., the output of the -h or -? options - shows this option, then task (thread) report‐
ing is supported by the dialect.)
When -K and -a are both specified on Linux, and the tasks of a main process are selected by other options,
the main process will also be listed as though it were a task, but without a task ID. (See the description
of the TID column in the OUTPUT section.)
Where the FreeBSD version supports threads, all threads will be listed with their IDs.
In general threads and tasks inherit the files of the caller, but may close some and open others, so lsof
always reports all the open files of threads and tasks.
-k k specifies a kernel name list file, k, in place of /vmunix, /mach, etc. -k is not available under AIX on the
IBM RISC/System 6000.
-l inhibits the conversion of user ID numbers to login names. It is also useful when login name lookup is
working improperly or slowly.
+|-L [l] enables (`+') or disables (`-') the listing of file link counts, where they are available - e.g., they
aren't available for sockets, or most FIFOs and pipes.
When +L is specified without a following number, all link counts will be listed. When -L is specified (the
default), no link counts will be listed.
When +L is followed by a number, only files having a link count less than that number will be listed. (No
number may follow -L.) A specification of the form ``+L1'' will select open files that have been unlinked.
A specification of the form ``+aL1 <file_system>'' will select unlinked open files on the specified file
system.
For other link count comparisons, use field output (-F) and a post-processing script or program.
+|-m m specifies an alternate kernel memory file or activates mount table supplement processing.
The option form -m m specifies a kernel memory file, m, in place of /dev/kmem or /dev/mem - e.g., a crash
dump file.
The option form +m requests that a mount supplement file be written to the standard output file. All other
options are silently ignored.
There will be a line in the mount supplement file for each mounted file system, containing the mounted file
system directory, followed by a single space, followed by the device number in hexadecimal "0x" format -
e.g.,
/ 0x801
Lsof can use the mount supplement file to get device numbers for file systems when it can't get them via
stat(2) or lstat(2).
The option form +m m identifies m as a mount supplement file.
Note: the +m and +m m options are not available for all supported dialects. Check the output of lsof's -h
or -? options to see if the +m and +m m options are available.
+|-M Enables (+) or disables (-) the reporting of portmapper registrations for local TCP, UDP and UDPLITE ports,
where port mapping is supported. (See the last paragraph of this option description for information about
where portmapper registration reporting is suported.)
The default reporting mode is set by the lsof builder with the HASPMAPENABLED #define in the dialect's
machine.h header file; lsof is distributed with the HASPMAPENABLED #define deactivated, so portmapper
reporting is disabled by default and must be requested with +M. Specifying lsof's -h or -? option will
report the default mode. Disabling portmapper registration when it is already disabled or enabling it when
already enabled is acceptable. When portmapper registration reporting is enabled, lsof displays the
portmapper registration (if any) for local TCP, UDP or UDPLITE ports in square brackets immediately follow‐
ing the port numbers or service names - e.g., ``:1234[name]'' or ``:name[100083]''. The registration infor‐
mation may be a name or number, depending on what the registering program supplied to the portmapper when it
registered the port.
When portmapper registration reporting is enabled, lsof may run a little more slowly or even become blocked
when access to the portmapper becomes congested or stopped. Reverse the reporting mode to determine if
portmapper registration reporting is slowing or blocking lsof.
For purposes of portmapper registration reporting lsof considers a TCP, UDP or UDPLITE port local if: it is
found in the local part of its containing kernel structure; or if it is located in the foreign part of its
containing kernel structure and the local and foreign Internet addresses are the same; or if it is located
in the foreign part of its containing kernel structure and the foreign Internet address is INADDR_LOOPBACK
(127.0.0.1). This rule may make lsof ignore some foreign ports on machines with multiple interfaces when
the foreign Internet address is on a different interface from the local one.
See the lsof FAQ (The FAQ section gives its location.) for further discussion of portmapper registration
reporting issues.
Portmapper registration reporting is supported only on dialects that have RPC header files. (Some Linux
distributions with GlibC 2.14 do not have them.) When portmapper registration reporting is supported, the
-h or -? help output will show the +|-M option.
-n inhibits the conversion of network numbers to host names for network files. Inhibiting conversion may make
lsof run faster. It is also useful when host name lookup is not working properly.
-N selects the listing of NFS files.
-o directs lsof to display file offset at all times. It causes the SIZE/OFF output column title to be changed
to OFFSET. Note: on some UNIX dialects lsof can't obtain accurate or consistent file offset information
from its kernel data sources, sometimes just for particular kinds of files (e.g., socket files.) Consult
the lsof FAQ (The FAQ section gives its location.) for more information.
The -o and -s options are mutually exclusive; they can't both be specified. When neither is specified, lsof
displays whatever value - size or offset - is appropriate and available for the type of the file.
-o o defines the number of decimal digits (o) to be printed after the ``0t'' for a file offset before the form is
switched to ``0x...''. An o value of zero (unlimited) directs lsof to use the ``0t'' form for all offset
output.
This option does NOT direct lsof to display offset at all times; specify -o (without a trailing number) to
do that. -o o only specifies the number of digits after ``0t'' in either mixed size and offset or off‐
set-only output. Thus, for example, to direct lsof to display offset at all times with a decimal digit
count of 10, use:
-o -o 10
or
-oo10
The default number of digits allowed after ``0t'' is normally 8, but may have been changed by the lsof
builder. Consult the description of the -o o option in the output of the -h or -? option to determine the
default that is in effect.
-O directs lsof to bypass the strategy it uses to avoid being blocked by some kernel operations - i.e., doing
them in forked child processes. See the BLOCKS AND TIMEOUTS and AVOIDING KERNEL BLOCKS sections for more
information on kernel operations that may block lsof.
While use of this option will reduce lsof startup overhead, it may also cause lsof to hang when the kernel
doesn't respond to a function. Use this option cautiously.
-p s excludes or selects the listing of files for the processes whose optional process IDentification (PID) num‐
bers are in the comma-separated set s - e.g., ``123'' or ``123,^456''. (There should be no spaces in the
set.)
PID numbers that begin with `^' (negation) represent exclusions.
Multiple process ID numbers are joined in a single ORed set before participating in AND option selection.
However, PID exclusions are applied without ORing or ANDing and take effect before other selection criteria
are applied.
-P inhibits the conversion of port numbers to port names for network files. Inhibiting the conversion may make
lsof run a little faster. It is also useful when port name lookup is not working properly.
+|-r [t[m<fmt>]]
puts lsof in repeat mode. There lsof lists open files as selected by other options, delays t seconds
(default fifteen), then repeats the listing, delaying and listing repetitively until stopped by a condition
defined by the prefix to the option.
If the prefix is a `-', repeat mode is endless. Lsof must be terminated with an interrupt or quit signal.
If the prefix is `+', repeat mode will end the first cycle no open files are listed - and of course when
lsof is stopped with an interrupt or quit signal. When repeat mode ends because no files are listed, the
process exit code will be zero if any open files were ever listed; one, if none were ever listed.
Lsof marks the end of each listing: if field output is in progress (the -F, option has been specified), the
default marker is `m'; otherwise the default marker is ``========''. The marker is followed by a NL charac‐
ter.
The optional "m<fmt>" argument specifies a format for the marker line. The <fmt> characters following `m'
are interpreted as a format specification to the strftime(3) function, when both it and the localtime(3)
function are available in the dialect's C library. Consult the strftime(3) documentation for what may
appear in its format specification. Note that when field output is requested with the -F option, <fmt> can‐
not contain the NL format, ``%n''. Note also that when <fmt> contains spaces or other characters that
affect the shell's interpretation of arguments, <fmt> must be quoted appropriately.
Repeat mode reduces lsof startup overhead, so it is more efficient to use this mode than to call lsof repet‐
itively from a shell script, for example.
To use repeat mode most efficiently, accompany +|-r with specification of other lsof selection options, so
the amount of kernel memory access lsof does will be kept to a minimum. Options that filter at the process
level - e.g., -c, -g, -p, -u - are the most efficient selectors.
Repeat mode is useful when coupled with field output (see the -F, option description) and a supervising awk
or Perl script, or a C program.
-R directs lsof to list the Parent Process IDentification number in the PPID column.
-s [p:s] s alone directs lsof to display file size at all times. It causes the SIZE/OFF output column title to be
changed to SIZE. If the file does not have a size, nothing is displayed.
The optional -s p:s form is available only for selected dialects, and only when the -h or -? help output
lists it.
When the optional form is available, the s may be followed by a protocol name (p), either TCP or UDP, a
colon (`:') and a comma-separated protocol state name list, the option causes open TCP and UDP files to be
excluded if their state name(s) are in the list (s) preceded by a `^'; or included if their name(s) are not
preceded by a `^'.
When an inclusion list is defined, only network files with state names in the list will be present in the
lsof output. Thus, specifying one state name means that only network files with that lone state name will
be listed.
Case is unimportant in the protocol or state names, but there may be no spaces and the colon (`:') separat‐
ing the protocol name (p) and the state name list (s) is required.
If only TCP and UDP files are to be listed, as controlled by the specified exclusions and inclusions, the -i
option must be specified, too. If only a single protocol's files are to be listed, add its name as an argu‐
ment to the -i option.
For example, to list only network files with TCP state LISTEN, use:
-iTCP -sTCP:LISTEN
Or, for example, to list network files with all UDP states except Idle, use:
-iUDP -sUDP:Idle
State names vary with UNIX dialects, so it's not possible to provide a complete list. Some common TCP state
names are: CLOSED, IDLE, BOUND, LISTEN, ESTABLISHED, SYN_SENT, SYN_RCDV, ESTABLISHED, CLOSE_WAIT, FIN_WAIT1,
CLOSING, LAST_ACK, FIN_WAIT_2, and TIME_WAIT. Two common UDP state names are Unbound and Idle.
See the lsof FAQ (The FAQ section gives its location.) for more information on how to use protocol state
exclusion and inclusion, including examples.
The -o (without a following decimal digit count) and -s option (without a following protocol and state name
list) are mutually exclusive; they can't both be specified. When neither is specified, lsof displays what‐
ever value - size or offset - is appropriate and available for the type of file.
Since some types of files don't have true sizes - sockets, FIFOs, pipes, etc. - lsof displays for their
sizes the content amounts in their associated kernel buffers, if possible.
-S [t] specifies an optional time-out seconds value for kernel functions - lstat(2), readlink(2), and stat(2) -
that might otherwise deadlock. The minimum for t is two; the default, fifteen; when no value is specified,
the default is used.
See the BLOCKS AND TIMEOUTS section for more information.
-T [t] controls the reporting of some TCP/TPI information, also reported by netstat(1), following the network
addresses. In normal output the information appears in parentheses, each item except TCP or TPI state name
identified by a keyword, followed by `=', separated from others by a single space:
<TCP or TPI state name>
QR=<read queue length>
QS=<send queue length>
SO=<socket options and values>
SS=<socket states>
TF=<TCP flags and values>
WR=<window read length>
WW=<window write length>
Not all values are reported for all UNIX dialects. Items values (when available) are reported after the
item name and '='.
When the field output mode is in effect (See OUTPUT FOR OTHER PROGRAMS.) each item appears as a field with
a `T' leading character.
-T with no following key characters disables TCP/TPI information reporting.
-T with following characters selects the reporting of specific TCP/TPI information:
f selects reporting of socket options,
states and values, and TCP flags and
values.
q selects queue length reporting.
s selects connection state reporting.
w selects window size reporting.
Not all selections are enabled for some UNIX dialects. State may be selected for all dialects and is
reported by default. The -h or -? help output for the -T option will show what selections may be used with
the UNIX dialect.
When -T is used to select information - i.e., it is followed by one or more selection characters - the dis‐
playing of state is disabled by default, and it must be explicitly selected again in the characters follow‐
ing -T. (In effect, then, the default is equivalent to -Ts.) For example, if queue lengths and state are
desired, use -Tqs.
Socket options, socket states, some socket values, TCP flags and one TCP value may be reported (when avail‐
able in the UNIX dialect) in the form of the names that commonly appear after SO_, so_, SS_, TCP_ and TF_
in the dialect's header files - most often <sys/socket.h>, <sys/socketvar.h> and <netinet/tcp_var.h>. Con‐
sult those header files for the meaning of the flags, options, states and values.
``SO='' precedes socket options and values; ``SS='', socket states; and ``TF='', TCP flags and values.
If a flag or option has a value, the value will follow an '=' and the name -- e.g., ``SO=LINGER=5'',
``SO=QLIM=5'', ``TF=MSS=512''. The following seven values may be reported:
Name
Reported Description (Common Symbol)
KEEPALIVE keep alive time (SO_KEEPALIVE)
LINGER linger time (SO_LINGER)
MSS maximum segment size (TCP_MAXSEG)
PQLEN partial listen queue connections
QLEN established listen queue connections
QLIM established listen queue limit
RCVBUF receive buffer length (SO_RCVBUF)
SNDBUF send buffer length (SO_SNDBUF)
Details on what socket options and values, socket states, and TCP flags and values may be displayed for par‐
ticular UNIX dialects may be found in the answer to the ``Why doesn't lsof report socket options, socket
states, and TCP flags and values for my dialect?'' and ``Why doesn't lsof report the partial listen queue
connection count for my dialect?'' questions in the lsof FAQ (The FAQ section gives its location.)
-t specifies that lsof should produce terse output with process identifiers only and no header - e.g., so that
the output may be piped to kill(1). -t selects the -w option.
-u s selects the listing of files for the user whose login names or user ID numbers are in the comma-separated
set s - e.g., ``abe'', or ``548,root''. (There should be no spaces in the set.)
Multiple login names or user ID numbers are joined in a single ORed set before participating in AND option
selection.
If a login name or user ID is preceded by a `^', it becomes a negation - i.e., files of processes owned by
the login name or user ID will never be listed. A negated login name or user ID selection is neither ANDed
nor ORed with other selections; it is applied before all other selections and absolutely excludes the list‐
ing of the files of the process. For example, to direct lsof to exclude the listing of files belonging to
root processes, specify ``-u^root'' or ``-u^0''.
-U selects the listing of UNIX domain socket files.
-v selects the listing of lsof version information, including: revision number; when the lsof binary was con‐
structed; who constructed the binary and where; the name of the compiler used to construct the lsof binary;
the version number of the compiler when readily available; the compiler and loader flags used to construct
the lsof binary; and system information, typically the output of uname's -a option.
-V directs lsof to indicate the items it was asked to list and failed to find - command names, file names,
Internet addresses or files, login names, NFS files, PIDs, PGIDs, and UIDs.
When other options are ANDed to search options, or compile-time options restrict the listing of some files,
lsof may not report that it failed to find a search item when an ANDed option or compile-time option pre‐
vents the listing of the open file containing the located search item.
For example, ``lsof -V -iTCP@foobar -a -d 999'' may not report a failure to locate open files at ``TCP@foo‐
bar'' and may not list any, if none have a file descriptor number of 999. A similar situation arises when
HASSECURITY and HASNOSOCKSECURITY are defined at compile time and they prevent the listing of open files.
+|-w Enables (+) or disables (-) the suppression of warning messages.
The lsof builder may choose to have warning messages disabled or enabled by default. The default warning
message state is indicated in the output of the -h or -? option. Disabling warning messages when they are
already disabled or enabling them when already enabled is acceptable.
The -t option selects the -w option.
-x [fl] may accompany the +d and +D options to direct their processing to cross over symbolic links and|or file sys‐
tem mount points encountered when scanning the directory (+d) or directory tree (+D).
If -x is specified by itself without a following parameter, cross-over processing of both symbolic links and
file system mount points is enabled. Note that when -x is specified without a parameter, the next argument
must begin with '-' or '+'.
The optional 'f' parameter enables file system mount point cross-over processing; 'l', symbolic link
cross-over processing.
The -x option may not be supplied without also supplying a +d or +D option.
-X This is a dialect-specific option.
AIX:
This IBM AIX RISC/System 6000 option requests the reporting of executed text file and shared library refer‐
ences.
WARNING: because this option uses the kernel readx() function, its use on a busy AIX system might cause an
application process to hang so completely that it can neither be killed nor stopped. I have never seen this
happen or had a report of its happening, but I think there is a remote possibility it could happen.
By default use of readx() is disabled. On AIX 5L and above lsof may need setuid-root permission to perform
the actions this option requests.
The lsof builder may specify that the -X option be restricted to processes whose real UID is root. If that
has been done, the -X option will not appear in the -h or -? help output unless the real UID of the lsof
process is root. The default lsof distribution allows any UID to specify -X, so by default it will appear
in the help output.
When AIX readx() use is disabled, lsof may not be able to report information for all text and loader file
references, but it may also avoid exacerbating an AIX kernel directory search kernel error, known as the
Stale Segment ID bug.
The readx() function, used by lsof or any other program to access some sections of kernel virtual memory,
can trigger the Stale Segment ID bug. It can cause the kernel's dir_search() function to believe erro‐
neously that part of an in-memory copy of a file system directory has been zeroed. Another application
process, distinct from lsof, asking the kernel to search the directory - e.g., by using open(2) - can cause
dir_search() to loop forever, thus hanging the application process.
Consult the lsof FAQ (The FAQ section gives its location.) and the 00README file of the lsof distribution
for a more complete description of the Stale Segment ID bug, its APAR, and methods for defining readx() use
when compiling lsof.
Linux:
This Linux option requests that lsof skip the reporting of information on all open TCP, UDP and UDPLITE IPv4
and IPv6 files.
This Linux option is most useful when the system has an extremely large number of open TCP, UDP and UDPLITE
files, the processing of whose information in the /proc/net/tcp* and /proc/net/udp* files would take lsof a
long time, and whose reporting is not of interest.
Use this option with care and only when you are sure that the information you want lsof to display isn't
associated with open TCP, UDP or UDPLITE socket files.
Solaris 10 and above:
This Solaris 10 and above option requests the reporting of cached paths for files that have been deleted -
i.e., removed with rm(1) or unlink(2).
The cached path is followed by the string `` (deleted)'' to indicate that the path by which the file was
opened has been deleted.
Because intervening changes made to the path - i.e., renames with mv(1) or rename(2) - are not recorded in
the cached path, what lsof reports is only the path by which the file was opened, not its possibly different
final path.
-z [z] specifies how Solaris 10 and higher zone information is to be handled.
Without a following argument - e.g., NO z - the option specifies that zone names are to be listed in the
ZONE output column.
The -z option may be followed by a zone name, z. That causes lsof to list only open files for processes in
that zone. Multiple -z z option and argument pairs may be specified to form a list of named zones. Any
open file of any process in any of the zones will be listed, subject to other conditions specified by other
options and arguments.
-Z [Z] specifies how SELinux security contexts are to be handled. It and 'Z' field output character support are
inhibited when SELinux is disabled in the running Linux kernel. See OUTPUT FOR OTHER PROGRAMS for more
information on the 'Z' field output character.
Without a following argument - e.g., NO Z - the option specifies that security contexts are to be listed in
the SECURITY-CONTEXT output column.
The -Z option may be followed by a wildcard security context name, Z. That causes lsof to list only open
files for processes in that security context. Multiple -Z Z option and argument pairs may be specified to
form a list of security contexts. Any open file of any process in any of the security contexts will be
listed, subject to other conditions specified by other options and arguments. Note that Z can be A:B:C or
*:B:C or A:B:* or *:*:C to match against the A:B:C context.
-- The double minus sign option is a marker that signals the end of the keyed options. It may be used, for
example, when the first file name begins with a minus sign. It may also be used when the absence of a value
for the last keyed option must be signified by the presence of a minus sign in the following option and
before the start of the file names.
names These are path names of specific files to list. Symbolic links are resolved before use. The first name may
be separated from the preceding options with the ``--'' option.
If a name is the mounted-on directory of a file system or the device of the file system, lsof will list all
the files open on the file system. To be considered a file system, the name must match a mounted-on direc‐
tory name in mount(8) output, or match the name of a block device associated with a mounted-on directory
name. The +|-f option may be used to force lsof to consider a name a file system identifier (+f) or a sim‐
ple file (-f).
If name is a path to a directory that is not the mounted-on directory name of a file system, it is treated
just as a regular file is treated - i.e., its listing is restricted to processes that have it open as a file
or as a process-specific directory, such as the root or current working directory. To request that lsof
look for open files inside a directory name, use the +d s and +D D options.
If a name is the base name of a family of multiplexed files - e. g, AIX's /dev/pt[cs] - lsof will list all
the associated multiplexed files on the device that are open - e.g., /dev/pt[cs]/1, /dev/pt[cs]/2, etc.
If a name is a UNIX domain socket name, lsof will usually search for it by the characters of the name alone
- exactly as it is specified and is recorded in the kernel socket structure. (See the next paragraph for an
exception to that rule for Linux.) Specifying a relative path - e.g., ./file - in place of the file's abso‐
lute path - e.g., /tmp/file - won't work because lsof must match the characters you specify with what it
finds in the kernel UNIX domain socket structures.
If a name is a Linux UNIX domain socket name, in one case lsof is able to search for it by its device and
inode number, allowing name to be a relative path. The case requires that the absolute path -- i.e., one
beginning with a slash ('/') be used by the process that created the socket, and hence be stored in the
/proc/net/unix file; and it requires that lsof be able to obtain the device and node numbers of both the
absolute path in /proc/net/unix and name via successful stat(2) system calls. When those conditions are
met, lsof will be able to search for the UNIX domain socket when some path to it is is specified in name.
Thus, for example, if the path is /dev/log, and an lsof search is initiated when the working directory is
/dev, then name could be ./log.
If a name is none of the above, lsof will list any open files whose device and inode match that of the spec‐
ified path name.
If you have also specified the -b option, the only names you may safely specify are file systems for which
your mount table supplies alternate device numbers. See the AVOIDING KERNEL BLOCKS and ALTERNATE DEVICE
NUMBERS sections for more information.
Multiple file names are joined in a single ORed set before participating in AND option selection.
AFS
Lsof supports the recognition of AFS files for these dialects (and AFS versions):
AIX 4.1.4 (AFS 3.4a)
HP-UX 9.0.5 (AFS 3.4a)
Linux 1.2.13 (AFS 3.3)
Solaris 2.[56] (AFS 3.4a)
It may recognize AFS files on other versions of these dialects, but has not been tested there. Depending on how AFS
is implemented, lsof may recognize AFS files in other dialects, or may have difficulties recognizing AFS files in the
supported dialects.
Lsof may have trouble identifying all aspects of AFS files in supported dialects when AFS kernel support is imple‐
mented via dynamic modules whose addresses do not appear in the kernel's variable name list. In that case, lsof may
have to guess at the identity of AFS files, and might not be able to obtain volume information from the kernel that
is needed for calculating AFS volume node numbers. When lsof can't compute volume node numbers, it reports blank in
the NODE column.
The -A A option is available in some dialect implementations of lsof for specifying the name list file where dynamic
module kernel addresses may be found. When this option is available, it will be listed in the lsof help output, pre‐
sented in response to the -h or -?
See the lsof FAQ (The FAQ section gives its location.) for more information about dynamic modules, their symbols,
and how they affect lsof options.
Because AFS path lookups don't seem to participate in the kernel's name cache operations, lsof can't identify path
name components for AFS files.
网友评论