1.用户名和密码修改或创建
默认的用户名和密码都是 admin,如果希望修改或添加新的用户,请参考下列命令:
OS10# configure terminal
OS10(config)# username admin password password_2018 role sysadmin
OS10(config)# end
OS10# write memory
2. 交换机的日期与时间
1配置本地时间
OS10# configure terminal
OS10(config)# clock timezone UTC 8 0
OS10(config)# end
OS10# clock set 22:49:00 2018-03-29
OS10# show clock
2018-03-29T22:49:10.06+08:00
OS10#write
2 NTP 校时
OS10(config)# clock timezone UTC 8 0
OS10(config)# do show clock
2018-03-30T06:26:15.24+08:00
OS10(config)# ntp server 192.168.220.159
OS10(config)# do write
3. 交换机的接口模式配置
1 Access 模式
例:创建 VLAN10 并将 e1/1/1 接口以 access 模式划入 vlan10.
OS10# configure terminal
OS10(config)# interface vlan 10
OS10(conf-if-vl-10)# exit
OS10(config)# interface e1/1/1
OS10(conf-if-eth1/1/1)# switchport mode access
OS10(conf-if-eth1/1/1)# switchport access vlan 10
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# do write
2Trunk 模式
例:创建 VLAN10 和 20,并将 e1/1/2 接口配置为 trunk 模式且放行 vlan10 和 20.
OS10# configure terminal
OS10(config)# interface vlan 20
OS10(conf-if-vl-20)# exit
OS10(config)# interface e1/1/2
OS10(conf-if-eth1/1/2)# switchport mode trunk
OS10(conf-if-eth1/1/2)# switchport trunk allowed vlan 10,20
OS10(conf-if-eth1/1/2)# show configuration
!
interface ethernet1/1/2
no shutdown
switchport mode trunk
switchport access vlan 1 (如果你希望 native vlan 为 2,此处请 switch access vlan 2 )
switchport trunk allowed vlan 10,20
OS10(conf-if-eth1/1/2)# do write memory
3修改默认 VLAN
OS10 默认 VLAN 是 1 且默认所有 trunk 口都 untagged vlan1,如果需要修改其他 VLAN 为
默认 VLAN,参考如下:
OS10# configure terminal
OS10(config)# interface vlan 4093
OS10(conf-if-vl-4093)# exit
OS10(config)# default vlan-id 4093
OS10(config)# do show vlan
Codes: * - Default VLAN, M - Management VLAN, R - Remote Port Mirroring VLANs
Q: A - Access (Untagged), T - Tagged
NUM Status Description Q Ports
1 Inactive
* 4093 Active A Eth1/1/1-1/1/32
OS10(config)#do write
4. 链路聚合配置
1静态链路聚合
本例:对 e1/1/49 和 50 接口静态聚合为 PO1,并且配置为 trunk 模式和放行 vlan10,20
OS10# configure terminal
OS10(config)# interface port-channel 1
OS10(conf-if-po-1)# switchport mode trunk
OS10(conf-if-po-1)# switchport trunk allowed vlan 10,20
OS10(conf-if-po-1)# no shutdown
OS10(conf-if-po-1)# exit
OS10(config)# interface range e1/1/49-1/1/50
OS10(conf-range-eth1/1/49-1/1/50)# channel-group 1
OS10(conf-range-eth1/1/49-1/1/50)# no shutdown
OS10(conf-range-eth1/1/49-1/1/50)# end
OS10#write
查看:
OS10# show interface port-channel 1 summary
2动态 LACP 聚合
OS10# configure terminal
OS10(config)# interface port-channel 1
OS10(conf-if-po-1)# switchport mode trunk
OS10(conf-if-po-1)# switchport trunk allowed vlan 10,20
OS10(conf-if-po-1)# no shutdown
OS10(conf-if-po-1)# exit
OS10(config)# interface range e1/1/49-1/1/50
OS10(conf-range-eth1/1/49-1/1/50)# channel-group 1 mode active
OS10(conf-range-eth1/1/49-1/1/50)# no shutdown
OS10(conf-range-eth1/1/49-1/1/50)# end
OOS100#write
查看:
OOS100# show interface port-channel 1 summary
5.本地端口镜像
本例中,将 e1/1/1 口的进和出两个方向的流量镜像到 e1/1/2 口进行抓包分析。
OS10(config)# interface e1/1/2
OS10(conf-if-eth1/1/2)# no switchport
OS10(conf-if-eth1/1/2)#exit
OS10(config)# monitor session 1
OS10(conf-mon-local-1)# source interface ethernet 1/1/1 both
OS10(conf-mon-local-1)# destination interface e1/1/2
OS10(conf-mon-local-1)# no shut
6.Syslog Host 配置
目前,OS10 默认使用 TCP 协议将日志传递给外部的 Syslog Server。所以请确保 syslog server
侦听 TCP 514 端口。
OS10 默认的日志级别为 notice。
OS10#config t
OS10(config)# logging log-file severity log-debug
OS10(config)# logging server 192.168.220.159 severity log-debug udp
OS10(config)# logging enable
OS10(config)# do write
另,如果需要启用审计日志功能(记录交换机用户的命令操作记录),如下
OS10(config)# logging audit enable
OS10(config)# show logging audit
7. SNMP 配置
本例,配置 snmp community 为 dell 且为只读
OS10# configure terminal
OS10(config)# snmp-server community dell ro
如果需要配置 snmp server 和启用 trap,则参考如下 :
OS10(config)# snmp-server host 1.1.1.1 version 2c dell
OS10(config)# snmp-server enable traps
OS10(config)# do write
8.交换机 IP 地址配置
1 带外管理 IP 配置
OS10# show running-configuration interface mgmt 1/1/1
!
interface mgmt1/1/1
no shutdown
ip address dhcp
ipv6 address autoconfig
OS10#
OS10# configure terminal
OS10(config)# interface mgmt 1/1/1
OS10(conf-if-ma-1/1/1)# no ip address dhcp
OS10(conf-if-ma-1/1/1)# no ipv6 address autoconfig
OS10(conf-if-ma-1/1/1)# exit
OS10(config)# ip vrf management
OS10(conf-vrf)# interface management
OS10(conf-vrf)# exit
OS10(config)# interface mgmt 1/1/1
OS10(conf-if-ma-1/1/1)# ip address 10.0.0.1/24
OS10(conf-if-ma-1/1/1)# no shutdown
OS10(conf-if-ma-1/1/1)# show configuration
!
interface mgmt1/1/1
no shutdown
no ip address dhcp
ip address 10.0.0.1/24
OS10(conf-if-ma-1/1/1)# exit
OS10#OS10(config)# management route 0.0.0.0/0 172.16.1.254 (带外网络默认路由)
OS10(config)#do write
2 带内管理 IP 配置
此处所谓带内是相对于带外而言,本例中指的是 VLAN 接口(SVI)IP 地址的配置:
OS10(config)# interface vlan 1
OS10(conf-if-vl-1)# ip address 192.168.1.1/24
OS10(conf-if-vl-1)# no shutdown
OS10(conf-if-vl-1)# exit
OS10(config)# ip route 0.0.0.0/0 192.168.1.254 (带内网络的默认网关)
OS10(config)# do write
备注:上述是以 VLAN 1 作为例子,请根据您的 VLAN 规划自行修改。
注意:如果同时配置了带内和带外默认路由,带外管理口 MGMT 1/1/1 必须划入
Management VRF 中,否则仅带内默认路由生效。
网友评论