美文网首页
CUIT-ACM 2017-01-16 新生训练赛 H - C

CUIT-ACM 2017-01-16 新生训练赛 H - C

作者: 河里的咸鱼 | 来源:发表于2017-01-18 12:48 被阅读0次

    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input
    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output
    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

    Sample Input
    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2

    Sample Output
    179

    本题为简单的prim算法
    可以把已连接部分记为距离零

    
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    using namespace std;
    int a[101][101];
    const int INF = 100000;
    int lowcost[5000];
    void Prim(int N)
    {
        int i,j,k,ans = 0;
        int min;
    
        for(i = 1; i<=N; i++)
        {
            lowcost[i] = a[1][i];
        }
        for(i = 1; i<=N; i++)
        {
            min = lowcost[i];
            k=i;
            for(j=1;j<=N;j++)
            {
                if(min > lowcost[j])
                {
                    min = lowcost[j];
                    k=j;
                }
            }
            ans+=min;
            lowcost[k] = INF;
     
            for(j=1; j<=N; j++)
            {
                if((a[k][j]<lowcost[j])&&(lowcost[j]<INF))
                {
                    lowcost[j]=a[k][j];
                }
            }
        }
        printf("%d\n",ans);
    }
    int main()
    {
        int n;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cin>>a[i][j];
            }
        }
        int m,q,p;
        cin>>m;
        while(m--)
        {
            cin>>p>>q;
            a[p][q]=0;
            a[q][p]=0;
        }
         Prim(n);
    }
    
    

    相关文章

      网友评论

          本文标题:CUIT-ACM 2017-01-16 新生训练赛 H - C

          本文链接:https://www.haomeiwen.com/subject/okjvbttx.html