题目
Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:
Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.
Your task is to find the sequence of discarded cards and the last, remaining card.
Input
Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.
Output
For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.
Sample Input
7
19
10
6
0
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
分析
这个题本身是个很简单的模拟题,至少还剩两张牌的时候将第一张扔出来,第二张放在最下面,最后输出把牌扔出来的序列和最后剩下的牌,我用stl库里面的queue来模拟这个过程,本身很简单的题,然而却因为输入1的时候后面有空格而pe到死。
ac代码
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;
int main(){
queue <int> qu;
vector <int> ans;
int n;
while(scanf("%d", &n) && n){
for(int i = 1; i <= n; ++i){
qu.push(i);
}
while(qu.size() > 1){
ans.push_back(qu.front());
qu.pop();
qu.push(qu.front());
qu.pop();
}
printf("Discarded cards:");
bool text = 1;
for(auto a : ans){
if(text){
text = 0;
}
else printf(",");
printf(" %d", a);
}
printf("\n");
printf("Remaining card: %d\n", qu.front());
qu.pop();
ans.clear();
}
return 0;
}
网友评论