美文网首页
求助数据结构关于树的问题

求助数据结构关于树的问题

作者: 郭宏杰 | 来源:发表于2019-07-17 22:49 被阅读0次

求助帖!MOOC浙江大学陈越老师的数据结构课-PTA3.3

03-树3 Tree Traversals Again (25 分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

图1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

上面的就是题目了,这是关于将堆栈中序遍历的树用后序遍历一遍。我的思路是先将堆栈的树利用操作(Pop/Push)与上一遍的操作(Pop/Push)关系确定树的结构,然后将树后序遍历!
下面是我的程序代码!

class Node(object):
    def __init__(self,left_child,right_child,value):
        self._left_child = left_child
        self._right_child = right_child
        self._value = value
    @property
    def left_child(self):
        return self._left_child
    @property
    def right_child(self):
        return self._right_child
    @property
    def value(self):
        return self._value
    @left_child.setter
    def left_child(self,value):
        self._left_child = value
    @right_child.setter
    def right_child(self,value):
        self._right_child = value
    @value.setter
    def value(self,value):
        self._value = vaule
def BulidTree(Tree):
    Tree = []
    Stack = []
    temp = 0
    Root = 0
    n = int(input())
    for i in range(n):
        Tree.append(0)
    for i in range(2*n):
        line = input().split()
        if line[0] == 'Push':
            indict = int(line[1])-1
            Tree[indict] = Node(None,None,int(line[1]))
            Stack.append(Tree[indict])
            if i!= 0:
                if last_operate == 'Push':
                    Stack[-2].left_child = int(line[1])
                if last_operate == 'Pop':
                    temp.right_child = int(line[1])
        if line[0] == 'Pop':
            temp = Stack.pop(-1)
            if i!= 0:
                if last_operate == 'Push':
                    temp.left_child = -1
                    temp.right_child = -1
                if last_operate == 'Pop':
                    temp.right_child = -1
        last_operate = line[0]
    if temp.right_child == 'None':
        temp.right_child = -1
    return Root,Tree
def postorder(Root,Tree):
    post_res = []
    if Root != -2:
        post_res += postorder(Tree[Root].left_child-1,Tree)
        post_res += postorder(Tree[Root].right_child-1,Tree)
        post_res.append(Tree[Root].value)
    return post_res
def printlist(list):
    print (" ".join(str(j) for j in list))
tree = []
Root,Tree = BulidTree(tree)
post_order = postorder(Root,Tree)
printlist(post_order)

当我提交结果是,PTA出错了!!!
我在编译器测试时符合各种情况,是我理解出问题了,还是漏掉了特定情况,求大神赐教!!

啊,markdown语法用的不好,写的太丑请原谅

3.3错误.png

相关文章

  • 求助数据结构关于树的问题

    求助帖!MOOC浙江大学陈越老师的数据结构课-PTA3.3 03-树3 Tree Traversals Again...

  • 【数据结构】线段树

    【数据结构】线段树 老规矩,简书 Makedown 兼容性差。附上 CSDN 的 【数据结构】线段树 问题 最后一...

  • mysql索引

    从数据结构角度 1、B+树索引(O(log(n))):关于B+树索引,可以参考MySQL索引背后的数据结构及算法原...

  • 手敲数据结构——使用二分搜索树实现Set

    关于实现二分搜索树,可以看前面的文章 手敲数据结构——二分搜索树

  • 数据结构 - 概要

    数组 链表 堆/栈/队列 树 数据结构 - 二叉树数据结构 - 二叉查找树数据结构 - 平衡二叉树数据结构 - A...

  • 结构与算法系列(二叉搜索树)

    关于树 对于树的数据结构大家都了解,只是树的类型有很多,所以可能又会对树产生一种陌生感。树其实就是由有限n(n>=...

  • golang实现二叉搜索树

    关于什么是二叉搜索树,不清楚的同学可以去看我写的这个数据结构与算法的网站 数据结构 首先我们定义需要的数据结构。注...

  • 一篇文章搞定面试中的二叉树题目(java实现)

    最近总结了一些数据结构和算法相关的题目,这是第一篇文章,关于二叉树的。先上二叉树的数据结构: 二叉树的题目普遍可以...

  • 一篇文章搞定面试中的二叉树题目(java实现)

    最近总结了一些数据结构和算法相关的题目,这是第一篇文章,关于二叉树的。 先上二叉树的数据结构: 二叉树的题目普遍可...

  • 二叉树常见面试题

    最近总结了一些数据结构和算法相关的题目,这是第一篇文章,关于二叉树的。先上二叉树的数据结构: 二叉树的题目普遍可以...

网友评论

      本文标题:求助数据结构关于树的问题

      本文链接:https://www.haomeiwen.com/subject/qpjhlctx.html