美文网首页
1146 Topological Order(25 分)

1146 Topological Order(25 分)

作者: _YuFan | 来源:发表于2018-08-14 12:05 被阅读0次

    This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

    image.png

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

    Output Specification:

    Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

    Sample Input:

    6 8
    1 2
    1 3
    5 2
    5 4
    2 3
    2 6
    3 4
    6 4
    5
    1 5 2 3 6 4
    5 1 2 6 3 4
    5 1 2 3 6 4
    5 2 1 6 3 4
    1 2 3 4 5 6
    
    

    Sample Output:

    3 4
    

    题意:
    给出一个有向图,并给出k个查询,输出所有不是拓扑排序的查查询。

    思路:
    1.记录每个点的next,入度。
    2.vector拷贝的相关操作:C++ vector拷贝使用总结

    题解:

    #include<cstdlib>
    #include<cstdio>
    #include<vector>
    using namespace std;
    //定义每个节点的入度和对应出去的节点
    struct node
    {
        int in = 0;
        vector<int> out;
    };
    int main() {
        int n, m;
        scanf("%d %d", &n, &m);
        vector<node> nodes(n + 1);
        int a, b;
        for (int i = 0; i < m; i++) {
            scanf("%d %d", &a, &b);
            nodes[a].out.push_back(b);
            nodes[b].in++;
        }
        int query;
        scanf("%d", &query);
        int cnt = 0;
        for (int i = 0; i < query; i++) {
            bool flag = true;
            //每次查询对nodes的副本进行修改。
            vector<node> tNodes(nodes);
            for (int j = 0; j < n; j++) {
                int t;
                scanf("%d", &t);
                //即使已经判断出来不是拓扑排序了,仍然需要接受剩下的输入。
                if (!flag) continue;
                if (tNodes[t].in == 0) {
                    for (int k = 0; k < tNodes[t].out.size(); k++) {
                        tNodes[tNodes[t].out[k]].in--;
                    }
                }
                else {
                    if (cnt != 0) printf(" ");
                    printf("%d", i);
                    cnt++;
                    flag = false;
                }
            }
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:1146 Topological Order(25 分)

          本文链接:https://www.haomeiwen.com/subject/szimbftx.html