美文网首页
PAT Advanced 1011. World Cup Bet

PAT Advanced 1011. World Cup Bet

作者: OliverLew | 来源:发表于2017-05-20 22:40 被阅读38次

    我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

    题目

    With the 2010 FIFA World Cup running, football fans the world over were
    becoming increasingly excited as the best players from the best teams doing
    battles for the World Cup trophy in South Africa. Similarly, football betting
    fans were putting their money where their mouths were, by laying all manner of
    World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning
    was simple: first select any three of the games. Then for each selected game,
    bet on one of the three possible results -- namely W for win, T for tie,
    and L for lose. There was an odd assigned to each result. The winner's odd
    would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.1  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the
    2nd game, and T for the 1st game. If each bet takes 2 yuans, then the
    maximum profit would be (4.1\times 3.1\times 2.5\times 65\%-1)\times 2 = 39.31 yuans (accurate up to 2 decimal places).

    Input Specification:

    Each input file contains one test case. Each case contains the betting
    information of 3 games. Each game occupies a line with three distinct odds
    corresponding to W, T and L.

    Output Specification:

    For each test case, print in one line the best bet of each game, and the
    maximum profit accurate up to 2 decimal places. The characters and the number
    must be separated by one space.

    Sample Input:

    1.1 2.5 1.7
    1.2 3.1 1.6
    4.1 1.2 1.1
    

    Sample Output:

    T T W 39.31
    

    思路

    比较简单的题,写了个不用数组的代码。

    代码

    最新代码@github,欢迎交流

    #include <stdio.h>
    
    int main()
    {
        char c;
        float odd, maxodd, maxprofit = 1;
    
        for(int i = 0; i < 3; i++)
        {
            maxodd = 0;
            for(int j = 0; j < 3; j++)
            {
                scanf("%f", &odd);
                if(maxodd < odd)
                {
                    maxodd = odd;
                    c = "WTL"[j];
                }
            }
            printf("%c ", c);
            maxprofit *= maxodd;
        }
        printf("%.2f", (maxprofit * 0.65 - 1) * 2);
    
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT Advanced 1011. World Cup Bet

          本文链接:https://www.haomeiwen.com/subject/tbzpxxtx.html