美文网首页
杭电acm1022 Train Problem I

杭电acm1022 Train Problem I

作者: cwhong | 来源:发表于2018-06-28 10:04 被阅读0次

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 40640 Accepted Submission(s): 15217

    Problem Description

    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

    image
    image.png
    image
     
    Input
     
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
     
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
     
    3 123 321 3 123 312
     
    Sample Output
     
    Yes. in in in out out out FINISH No. FINISH
     
    Hint
     
    Hint 
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
     
    So we output "No.".

    Solution

    //栈和队列的使用

    Code

    /*
    *date:2017.11.09
    *author:孟小德
    *function:蓝桥杯试题
    *   模拟栈
    */
     
     
     
    import java.util.*;
     
    public class acm1022
    {
        public static void main(String[] args)
        {
            Scanner input = new Scanner(System.in);
     
            ArrayList<int[]> resultList = new ArrayList<int[]>();
            while (input.hasNextInt())
            {
                int num = input.nextInt();
     
                String pushstring = input.next();
                String popstring = input.next();
     
                String[] pushStr = new String[num];
                String[] popStr = new String[num];
                Stack<String> stack = new Stack<String>();
                int[] result = new int[2*num + 1];
     
                //分割字符串
                for (int i=0;i<num;i++)
                {
                    pushStr[i] = pushstring.substring(i,i+1);
                    popStr[i] = popstring.substring(i,i+1);
                }
     
                result[0] = 1;
                int pop_index = 0;
                int push_index = 0;
                int j = 1;
                while (pop_index != num)
                {
                    if (stack.empty() == true && push_index != num)
                    {
                        stack.push(pushStr[push_index]);
                        push_index++;
                        result[j] = 1;
                        j++;
                    }
                    else if (stack.empty() == false && push_index !=num)
                    {
                        if (popStr[pop_index].equals(stack.peek()))
                        {
                            stack.pop();
                            pop_index++;
                            result[j] = -1;
                            j++;
                        }
                        else
                        {
                            stack.push(pushStr[push_index]);
                            push_index++;
                            result[j] = 1;
                            j++;
                        }
                    }
                    else if (stack.empty() == false && push_index ==num)
                    {
                        if (popStr[pop_index].equals(stack.peek()))
                        {
                            stack.pop();
                            pop_index++;
                            result[j] = -1;
                            j++;
                        }
                        else
                        {
                            result[0] = 0;
                            break;
                        }
                    }
                    else
                    {
                        break;
                    }
                }
     
                resultList.add(result);
            }
     
     
     
            //输出结果
            for (int k = 0;k<resultList.size();k++)
            {
     
                if (resultList.get(k)[0] == 1)
                {
                    System.out.println("Yes.");
                    for (int i=1;i<resultList.get(k).length;i++)
                    {
                        if (resultList.get(k)[i] == 1)
                        {
                            System.out.println("in");
                        }
                        else
                        {
                            System.out.println("out");
                        }
                    }
                }
                else
                {
                    System.out.println("No.");
                }
                System.out.println("FINISH");
            }
     
        }
    }
    
    

    相关文章

      网友评论

          本文标题:杭电acm1022 Train Problem I

          本文链接:https://www.haomeiwen.com/subject/tkzwyftx.html