丑数

作者: 步行植物 | 来源:发表于2019-06-21 08:15 被阅读0次

问题 B: 丑数

时间限制: 1 Sec 内存限制: 32 MB
提交: 1948 解决: 490
[提交][状态][讨论版]</center>

题目描述

如果一个数的素因子只包含2,3,5或7,那么我们把这种数叫做丑数。序列1,2,3,4,5,6,7,8,9,10,12,14,15,16,18,20,21,24,25,27...展示了前20个丑数。
请你编程寻找这个序列中的第n个元素。

输入

输入包含多组测试数据。每组输入为一个整数n(1<=n<=5842),当n=0时,输入结束。

输出

对于每组输入,输出一行“The nth humble number is number.”。里面的n由输入中的n值替换,“st”,“nd”,“rd”和“th”这些序数结尾的用法参照输出样例。

样例输入

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0</pre>

样例输出

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.</pre>

#include<iostream>
#include<queue>
//#include <fstream>
using namespace std;

int main()
{
    priority_queue<long long, vector<long long>, greater<long long> > q;        //从小到大的排列
    vector<long long> number;
    q.push(1);
    q.push(2);
    long long current;
    while (1)
    {
        current = q.top();
        q.pop();
        if (number.size() == 5843)
            break;
        if (current != q.top())     //如果重复了就跳过
        {
            number.push_back(current);
            q.push(current * 2);
            q.push(current * 3);
            q.push(current * 5);
            q.push(current * 7);
        }
    }
    int num=1;
    while (1)
    {
        cin >> num;
        if (num == 0)
            break;
        cout << "The " << num;
        int last = num % 100;
        if (last == 1)
            cout << "st";
        else if (last == 2)
            cout << "nd";
        else if (last == 3)
            cout << "rd";
        else if (last > 13)
        {
            last = last % 10;
            if (last == 1)
                cout << "st";
            else if (last == 2)
                cout << "nd";
            else if (last == 3)
                cout << "rd";
            else
                cout << "th";
        }
        else
            cout << "th";
        cout << " humble number is " << number[num-1] << "." << endl;

    }
    //ofstream outstuf;    //建立输出流对象
    //outstuf.open("own.txt", ios::out); //以输出方式打开文件
    
    return 0;
}

相关文章

  • 263、丑数(E)

    判断一个正整数是否为一个丑数。丑数的定义是 1 为丑数,只包含 2、3、5的数就是丑数,比如 4,8,但是14 就...

  • golang实现剑指offer:动态规划题型

    丑数 LeetCode 面试题49:丑数 题目描述 我们把只包含因子 2、3 和 5 的数称作丑数(Ugly Nu...

  • 剑指offer学习笔记:5.3 时间效率与空间效率的平衡

    面试题34:丑数我们把只包含因子2,3,5的数称为丑数。求按从小到大排列的第1500个丑数。例如,6,8都是丑数,...

  • 每周 ARTS 第 11 期

    1. Algorithm 263. 丑数(简单) 描述: 编写一个程序判断给定的数是否为丑数。丑数就是只包含质因数...

  • 丑数

    1.题目描述 把只包含因子2、3和5的数称作丑数(Ugly Number)。例如6、8都是丑数,但14不是,因为它...

  • 丑数

    丑数 设计一个算法,找出只含素因子2,3,5的第n小的数。 符合条件的数如:1, 2, 3, 4, 5, 6, 8...

  • 丑数

    问题描述:把只包含因子2、3和5的数称作丑数(Ugly Number)。例如6、8都是丑数,但14不是,因为它包含...

  • 丑数

    题目描述 把只包含质因子2、3和5的数称作丑数(Ugly Number)。例如6、8都是丑数,但14不是,因为它包...

  • 丑数

    把只包含质因子2、3和5的数称作丑数(Ugly Number)。例如6、8都是丑数,但14不是,因为它包含质因子7...

  • 丑数

    题目49:丑数 我们把只包含因子2、3 和5 的数称作丑数(Ugly Number)。求从小到大的顺序的第1500...

网友评论

      本文标题:丑数

      本文链接:https://www.haomeiwen.com/subject/ugdeqctx.html