美文网首页
poj2431 Expedition

poj2431 Expedition

作者: 科学旅行者 | 来源:发表于2016-07-26 13:48 被阅读91次

    题目:

    Description
    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
    Input

    • Line 1: A single integer, N * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. * Line N+2: Two space-separated integers, L and P
      Output
    • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
      Sample Input
      4
      4 4
      5 2
      11 5
      15 10
      25 10
      Sample Output
      2

    题意大概是给你要去的终点的距离以及初始的汽油,路上会有N个加油站,每个加油站都有相应的油可以加(汽车油桶无限大)。问到达终点站最少要加多少次油(如果无法到达,则输出-1)。

    题目分类:贪心 & 优先队列。

    此题可以用贪心法,由于要加最少次数,因此最好的情况就是到0时再加,而加油方式我们可以理解为先把油存起来,不够到下一个加油站了在加这些油,因此此题就是尽量先用加油的量多的油以减少中途的加油次数。因此我们可以用优先队列(最大堆的情况),油不够就取,如果队列为空还未到达终点就为-1.

    注意:此题的距离是到终点的距离,另外需要先对距离排序(输入时可能无序)。

    参考代码:

    #include <iostream>
    #include <queue>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    struct xy {
        int loc;
        int units;
    }a[10005];
    bool cmp(xy a1,xy a2) {
        return a1.loc < a2.loc;
    }
    int main() {
        int n;
        int l,p;
        while (cin >> n) {
            memset(a,0,sizeof(a));
            for (int i = 0;i < n;++i) {
                cin >> a[i].loc >> a[i].units;
            }
            cin >> l >> p;
            for (int i = 0;i < n;++i) {
                a[i].loc = l - a[i].loc;
            }
            a[n].loc = l;//把终点也当做加油站;
            a[n++].units = 0;
            sort(a,a+n,cmp);
            priority_queue<int> que;
            int ans = 0,pos = 0,tank = p;
            for (int i = 0;i < n;++i) {
                int d = a[i].loc - pos;
                while (tank - d < 0) {
                    if (que.empty()) {
                        cout << "-1" << endl;
                        return 0;
                    }
                    else {
                        ans++;
                        tank = tank + que.top();
                        que.pop();
                    }
                }
                pos = a[i].loc;
                que.push(a[i].units);
                tank = tank - d;
            }
            cout << ans << endl;
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:poj2431 Expedition

          本文链接:https://www.haomeiwen.com/subject/vjmnjttx.html