美文网首页
杭电acm1062 Text Reverse

杭电acm1062 Text Reverse

作者: cwhong | 来源:发表于2018-06-28 09:56 被阅读0次

Text Reverse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34449 Accepted Submission(s): 13532

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 
Output
For each test case, you should output the text which is processed.
 
Sample Input
3 olleh !dlrow m'I morf .udh I ekil .mca
 
Sample Output
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

Solution

//简单的字符串处理

Code

/**
 * date:2017.11.12
 * author:孟小德
 * function:acm试题1062
 *  Text Reverse 文本倒置
 */
 
 
 
import java.util.*;
 
public class acm1062
{
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);
 
        int num = input.nextInt();
        input.nextLine();
 
        String[] string = new String[num];
        for (int i=0;i<num;i++)
        {
            string[i] = input.nextLine();
        }
 
        String[] result = new String[num];
        for (int i=0;i<num;i++)
        {
 
            String[] str = string[i].split(" ");    //分割字符串
 
            result[i] = stringReverse(str[0]);
            for (int j = 1;j<str.length;j++)
            {
                result[i] = result[i] + " " + stringReverse(str[j]);
            }
 
            //末尾空格加上
            int n = string[i].length() - result[i].length();
            for (int j = 0;j<n;j++)
            {
                result[i] += " ";
            }
 
        }
 
        for (int i = 0;i<num;i++)
        {
            System.out.println(result[i]);
        }
    }
 
    //翻转单词字母
    public static String stringReverse(String str)
    {
 
        if (str.equals(""))
        {
            return "";
        }
        else
        {
            String string = String.valueOf(str.charAt(str.length()-1));
            for (int i=str.length()-2;i>=0;i--)
            {
                string += String.valueOf(str.charAt(i));
 
            }
 
            return string;
        }
    }
}

相关文章

  • 杭电acm1062 Text Reverse

    Text Reverse Time Limit: 2000/1000 MS (Java/Others) Me...

  • 杭电助手

    杭电助手(服务号hduhelp,订阅号hduhelper)是隶属于杭州电子科技大学党委学工部的校级组织,我们有前端...

  • 杭电2015

    这道题看起来不复杂,但做起来还是挺费工夫的。里面要用很多的循环结构,很容易在些小地方出错。我就是因为那些小问题而搞...

  • 杭电打卡

    这题主要是数学方法求解,其他没什么难度,关键是得出递推公式。 假如第一个和最后一个格子能相同颜色,我们可以很快算出...

  • 杭电oj 第11页 java版答案

    杭电oj 第2000- 2099 题 全答案杭电oj 第十一页答案 具体路径在 src/main/java/com...

  • 杭电ACM1001

    不再更新,杭电ACM的题转到csdn博客

  • 杭电ACM(1013)

  • 二零一七杭电赏梅

    西邻专司花千尊, 东毗惟和草万匀, 纷落梅卿诱草生, 葱绿淡粉妆美人。

  • 杭电-1009 elevator

    这题就是简单的计算,没什么坑直接就ac了,注意更新当前电梯的位置就行。 AC代码

  • 杭电oj 1004

    杭电oj的1004 从这个题开始 我会把自己ac的题目放在简书上方便自己查看 也顺便帮助别人吧

网友评论

      本文标题:杭电acm1062 Text Reverse

      本文链接:https://www.haomeiwen.com/subject/vnawyftx.html