美文网首页
杭电acm1062 Text Reverse

杭电acm1062 Text Reverse

作者: cwhong | 来源:发表于2018-06-28 09:56 被阅读0次

    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 34449 Accepted Submission(s): 13532

    Problem Description

    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
    3 olleh !dlrow m'I morf .udh I ekil .mca
     
    Sample Output
    hello world! I'm from hdu. I like acm.
    Hint
    Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

    Solution

    //简单的字符串处理

    Code

    /**
     * date:2017.11.12
     * author:孟小德
     * function:acm试题1062
     *  Text Reverse 文本倒置
     */
     
     
     
    import java.util.*;
     
    public class acm1062
    {
        public static void main(String[] args)
        {
            Scanner input = new Scanner(System.in);
     
            int num = input.nextInt();
            input.nextLine();
     
            String[] string = new String[num];
            for (int i=0;i<num;i++)
            {
                string[i] = input.nextLine();
            }
     
            String[] result = new String[num];
            for (int i=0;i<num;i++)
            {
     
                String[] str = string[i].split(" ");    //分割字符串
     
                result[i] = stringReverse(str[0]);
                for (int j = 1;j<str.length;j++)
                {
                    result[i] = result[i] + " " + stringReverse(str[j]);
                }
     
                //末尾空格加上
                int n = string[i].length() - result[i].length();
                for (int j = 0;j<n;j++)
                {
                    result[i] += " ";
                }
     
            }
     
            for (int i = 0;i<num;i++)
            {
                System.out.println(result[i]);
            }
        }
     
        //翻转单词字母
        public static String stringReverse(String str)
        {
     
            if (str.equals(""))
            {
                return "";
            }
            else
            {
                String string = String.valueOf(str.charAt(str.length()-1));
                for (int i=str.length()-2;i>=0;i--)
                {
                    string += String.valueOf(str.charAt(i));
     
                }
     
                return string;
            }
        }
    }
    
    

    相关文章

      网友评论

          本文标题:杭电acm1062 Text Reverse

          本文链接:https://www.haomeiwen.com/subject/vnawyftx.html