题目:
Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 注意:两个城市之间可以有多条道路相通,也就是说3 31 21 22 1这种输入也是合法的当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
Hint
Hint
- *Huge input, scanf is recommended.
此题可以用并查集解决。
如果两个点是连通的,那么这两个点肯定属于同一个集合;如果所有的点都连通了,那么整个城镇的点就只有一个集合。
因此,我们可以用并查集将所有的点并入相应的集合,看最终还剩多少个集合。
参考代码:
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdio>
#define N 1000+20
using namespace std;
int par[N],ranki[N];
void init(int n) {
for (int i = 1;i <= n;++i) {
par[i] = i;
ranki[i] = 1;
}
}
int find(int x) {
if (x == par[x]) return x;
else return par[x] = find(par[x]);
}
void unite(int x,int y) {
int tx = find(x);
int ty = find(y);
if (tx != ty) {
if (ranki[tx] > ranki[ty]) {
par[ty] = tx;
ranki[tx] += ranki[ty];
}
else {
par[tx] = ty;
ranki[ty] += ranki[tx];
}
}
}
int main() {
int n,m;
while (scanf("%d", &n) != EOF && n) {
scanf("%d", &m);
init(n);
int s,t;
for (int i = 1;i <= m;++i) {
scanf("%d%d", &s, &t);
unite(s,t);
}
int cnt = -1;
for (int i = 1;i <= n;++i) {
if (par[i] == i) {
cnt++;
}
}
//if (cnt == 0 || cnt == n - 1) cnt = cnt;
//else cnt = cnt - 1;
printf("%d\n", cnt);
}
return 0;
}
注意此题的输入:先判断n,再输入m.
网友评论