美文网首页
Reversing Linked List

Reversing Linked List

作者: 我是阿喵酱 | 来源:发表于2018-02-04 16:36 被阅读0次

    02-线性结构3 Reversing Linked List(25 分)
    Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
    ​5
    ​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    where Address is the position of the node, Data is an integer, and Next is the position of the next node.

    Output Specification:

    For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

    Sample Input:

    00100 6 4
    00000 4 99999
    00100 1 12309
    68237 6 -1
    33218 3 00000
    99999 5 68237
    12309 2 33218
    Sample Output:

    00000 4 33218
    33218 3 12309
    12309 2 00100
    00100 1 99999
    99999 5 68237
    68237 6 -1

    java过不去
    #include<iostream>
    #include<cstring>
    using namespace std;
      
    struct data
    {
    int add;
    int d;
    int next;
    };
      
    int main()
    {
    int first,N,K,m=0,num=0;
    cin>>first>>N>>K;
    data a[100000];
    data p[100000];
    data aa[100000];
    data res[100000];
      
    int i,j;
    for(i=0;i<N;i++)
    {
        cin>>a[i].add;
        cin>>a[i].d;
        cin>>a[i].next;
        p[a[i].add].d=a[i].d;
        p[a[i].add].next=a[i].next;
    }
      
      
    i=0;
    while(first!=-1)
    {
    aa[i].add=first;
    aa[i].d=p[first].d;
    aa[i].next=p[first].next;
    first=p[first].next;
    num++;
    i++;
    }
      
    N=num;//可能有节点不在链表上
    /*赋值法for(i=0;i<N/K;i++)
    {
        for(j=K*i;j<K*(i+1);j++)
        {
        res[m]=aa[K*(2*i+1)-1-j];
        m++;
        }
      
    }
    for(i=m;i<N;i++)
    {
    res[i]=aa[i];
    }*/
    data temp;
    for(i=0;i<N/K;i++)
    {
        for(j=K*i;j<K*i+K/2;j++)
        {
        temp=aa[K*(2*i+1)-1-j];
        aa[K*(2*i+1)-1-j]=aa[j];
        aa[j]=temp;
        }
    }
      
    for(i=0;i<N-1;i++)
    {
    printf("%05d %d %05d\n",aa[i].add,aa[i].d,aa[i+1].add);
    }
    printf("%05d %d %d\n",aa[i].add,aa[i].d,-1);
      
      
      
    return 0;
    }
    

    相关文章

      网友评论

          本文标题:Reversing Linked List

          本文链接:https://www.haomeiwen.com/subject/wcossxtx.html