美文网首页
PAT Advanced 1036. Boys vs Girls

PAT Advanced 1036. Boys vs Girls

作者: OliverLew | 来源:发表于2020-04-29 00:10 被阅读0次

    我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

    题目

    This time you are asked to tell the difference between the lowest grade of all
    the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer
    N , followed by N lines of student information. Each line contains a
    student's name, gender, ID and grade, separated by a space, where
    name and ID are strings of no more than 10 characters with no space,
    gender is either F (female) or M (male), and grade is an integer
    between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of
    the female student with the highest grade, and the second line gives that of
    the male student with the lowest grade. The third line gives the difference
    grade_F-grade_M . If one such kind of student is missing, output Absent in
    the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    

    思路

    记录最大和最小,应该无需讲解了。

    代码

    最新代码@github,欢迎交流

    #include <stdio.h>
    
    typedef struct student {
        char name[11];
        char gender;
        char ID[11];
    } Student;
    
    int main()
    {
        int N, grade, gradeF = -1, gradeM = 101;
        Student students[101] = {0}, s;
    
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
        {
            scanf("%s %c %s %d", s.name, &s.gender, s.ID, &grade);
            students[grade] = s;
            if(s.gender == 'F')
                gradeF = grade > gradeF ? grade : gradeF;
            else
                gradeM = grade < gradeM ? grade : gradeM;
        }
    
        if(gradeF != -1)
            printf("%s %s\n", students[gradeF].name, students[gradeF].ID);
        else
            printf("Absent\n");
    
        if(gradeM != 101)
            printf("%s %s\n", students[gradeM].name, students[gradeM].ID);
        else
            printf("Absent\n");
    
        if(gradeM == 101 || gradeF == -1)
            printf("NA");
        else
            printf("%d", gradeF - gradeM);
    
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT Advanced 1036. Boys vs Girls

          本文链接:https://www.haomeiwen.com/subject/wphwwhtx.html