IOS 基本操作命令
简介
Cisco 的网际操作系统(IOS: Internetwork Operation System),IOS配置通常是通过基于文本的命令行接口(Command Line Interface, CLI)进行的。
路由基本操作
- 用户模式
Router>
通常可以查看统计信息
Router> logout
退出用户模式
Router>?
Exec commands:
<1-99> Session number to resume
connect Open a terminal connection
disable Turn off privileged commands
disconnect Disconnect an existing network connection
enable Turn on privileged commands
exit Exit from the EXEC
logout Exit from the EXEC
ping Send echo messages
resume Resume an active network connection
show Show running system information
ssh Open a secure shell client connection
telnet Open a telnet connection
terminal Set terminal line parameters
traceroute Trace route to destination
用户模式下通过“?”可以查看的命令。
- 特权模式
Router> enable
Router#
进入特权模式,特权模式是从用户模式进入的,用于查看和修改路由器的配置。
Router# disable
退出特权模式
- 全局配置模式
Route# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
进入全局配置模式,全局配置模式从特权模式进入,在全局配置模式中,一旦做修改,就会影响整个路由器。
进入全局模式想要退出,可以使用exit
Router(config)#exit
也可以使用快捷键 ctrl+z
- 接口配置模式
Router(config)#int fastEthernet 1/0
Router(config-if)#
可以通过指定接口,转到指定的接口配置模式。
如何使用帮助
- 时钟(clock)设置
Router#clock set [hh:mm:ss] [day] [month] [year]
day和month的顺序可变..month要用英文 可简写(前3字母)
设置成功之后,可以使用 show clock 命令查看。
Router#clock set ?
hh:mm:ss Current Time
Router#clock set 23:48:00 ?
<1-31> Day of the month
MONTH Month of the year
Router#clock set 23:48:00 24 Mar ?
<1993-2035> Year
Router#clock set 23:48:00 24 Mar 2017 ?
<cr>
Router#show clock
*23:30:4.540 UTC Fri Mar 24 2017
支持的快捷键
|快捷键|功能|
|::|::|
|ctrl+u|从光标所在位置删除到行首|
|ctrl+a|光标移动到行首|
|ctrl+e|光标移动到行尾|
|上下箭头|调用前一个(后一个)命令|
历史命令
Router#show terminal
... 省略 ...
Editing is enabled.
History is enabled, history size is 10. <--- 历史命令保存条数
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are All.
Allowed output transports are pad telnet rlogin.
Preferred transport is telnet.
No output characters are padded
No special data dispatching characters
查看终端配置与历史命令保存数
Router#show history
enable
show history
show terminal
show history
查看历史命令
修改历史命令的大小
Router#terminal history size ?
<0-256> Size of history buffer
Router#terminal history size 256
Router#show terminal
... 省略 ...
Editing is enabled.
History is enabled, history size is 256. <--- 修改为 256 条
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are All.
Allowed output transports are pad telnet rlogin.
Preferred transport is telnet.
No output characters are padded
No special data dispatching characters
路由器的历史命令是存放在闪存当中,但是路由器的闪存是非常小的,价格昂贵的路由器闪存可以达到128M,但是常见路由器闪存多是64M。所以说10条历史命令是合理的。
- 查看IOS系统版本
我们可以通过 show version 命令来查看IOS系统版本
Router>show version
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 06:21 by pt_rel_team
ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
2 Low-speed serial(sync/async) network interface(s)
... 省略 ...
239K bytes of NVRAM.
62720K bytes of processor board System flash (Read/Write) <--- 在这里我们可以看到闪存的信息
Configuration register is 0x2102
路由器关键信息设置
- 修改路由器名称
Router>enable
Router#configu
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router0
Router0(config)#
- 设置登陆提示信息
定义日期信息标记
Router0(config)#banner motd E <--- 分隔定界符,可以是任意字符
Enter TEXT message. End with the character 'E'.
Asia/Beijing TimeZone
E <--- 在输入结束后,可以再次输入E(分隔定界符),回车退出保存
Router0(config)#
定义登陆信息标记
登陆信息标记在 motd 标记区之后,在用户名和口令登陆提示之前显示
Router0(config)#banner login E
Enter TEXT message. End with the character 'E'.
hello Renkeju
E
Router0(config)#no banner login <--- 取消登陆信息标记
在设置这些信息之后,需要使用 copy run start (copy running-config start-config)来进行保存
Router0#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
之后我们再次进行登陆,就可以看到刚才设置的信息
Press RETURN to get started.
Asia/Beijing TimeZone
设置口令
- 路由器密码:
接口密码
一旦登陆,不能输入任何命令,需要马上输入
|接口|特性|
|::|::|
|console口密码|本地接口,所以不用密码也可以管理|
|虚拟接口密码|telnet 密码
ssh 密码|
|aux接口|本地接口,所以不用密码也可以管理|
- 特权模式密码
登陆之后,执行 enable 命令,进入特权模式时需要
设置特权模式密码
Router0>config
Router0#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router0(config)#enbabl
Router0(config)#enable password 123 --> 设置特权明文口令
Router0(config)#enable secret 456 --> 设置特权加密口令
加密口令优先级更高,如果设置了加密密码,则非加密密码不可使用
之后我们在登陆一次
Router0>enable
Password: <--- 输入加密密码
Router0#
使用 show run 查看配置
Router0#show run
... 省略 ...
hostname Router0
!
!
!
enable secret 5 $1$mERr$DqFv/bNKU3CFm5jwSLasx/ <-- MD5加密密码
enable password 123 <-- 明文密码
!
!
... 省略 ...
取消明文密码
Router0(config)#no enable password
Router0(config)#exit
Router0#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router0#show run
Router0#show running-config
... 省略 ...
!
enable secret 5 $1$mERr$DqFv/bNKU3CFm5jwSLasx/
!
... 省略 ...
设置console端口登陆口令
Router0#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router0(config)#line ?
<2-499> First Line number
aux Auxiliary line
console Primary terminal line
tty Terminal controller
vty Virtual terminal
x/y/z Slot/Subslot/Port for Modems
Router0(config)#line console ?
<0-0> First Line number
Router0(config)#line console 0
Router0(config-line)#login
R0(config-line)#login <--- 表示进入了接口模式
% Login disabled on line 0, until 'password' is set <--- 启用密码检查,也就是让密码生效,如果没有密码,就会报错
R0(config-line)#password 123 <--- 设置密码 123
R0(config-line)#login <--- 启用密码检查
R0(config-line)#
在接口模式中,可以设置会话超时时间
设定登录之后,多久超时。格式是 0分0秒,既永不超时。默认设置是10分钟不操作,直接踢出登录。
R0(config-line)#exec-timeout 0 0
R0(config-line)#exec-timeout 5 30
阻止控制台信息,避免打扰命令输入
R0(config-line)#logging synchronous
保存信息后,退出再登录一下
User Access Verification
Password:
R0>en
R0>enable
Password:
R0#
- 设置telnet 登录口令
R0(config)#line vty ?
<0-15> First Line number
R0(config)#line vty 0 15
R0(config-line)#password 123
R0(config-line)#login
R0(config-line)#
telnet登录不安全,请避免使用
R0(config)#line vty 0 15
R0(config-line)#no login
允许telnet无密码登录(不安全,不允许使用)
使用 show run 命令查看一下
... 省略 ...
line con 0
exec-timeout 5 30
password 123
logging synchronous
login
!
line aux 0
!
line vty 0 4
password 123
no login <--- 有密码 但是不允许登录
line vty 5 15
password 123
no login
!
!
!
end
- 密码加密
密码除了router(config)#enable secret 456 密码是加密保存,其他密码都是明文保存,可以通过:
R0(config)#service password-encryption
R0(config)#exit
R0#
%SYS-5-CONFIG_I: Configured from console by console
R0#show running-config
Building configuration...
Current configuration : 824 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R0
!
!
!
enable secret 5 $1$mERr$8Sw4Lxp39isOTo0nyfSTZ1
!
... 省略 ...
!
line con 0
exec-timeout 5 30
password 7 08701E1D
logging synchronous
login
!
line aux 0
!
line vty 0 4
password 7 08701E1D
no login
line vty 5 15
password 7 08701E1D <--- 刚才的明文密码变为了加密密码
no login
可以开启加密服务,所有的密码都会密文保存
- ssh 登录
- 设置用户名和域名
R0(config)#hostname R0
R0(config)#ip domain-name renkeju
修改主机名和域名,生成秘钥时需要用到
必须设定路由器时间
R0#clock set 18:38:00 25 Mar 2017
R0#show clock
*18:38:3.157 UTC Sat Mar 25 2017
- 生产加密秘钥
R0(config)#crypto key generate rsa general-keys modulus 1024
使用 rsa 加密,生成 1024 位密钥,如果密钥位数小于768位,则不能使用2代ssh协议。
R0(config)#crypto key generate rsa
The name for the keys will be: R0.renkeju
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
虚拟机使用此命令
- 设定登录密码
R0(config)#aaa new-model
R0(config)#username cisco password cisco
启用 AAA (Authentication Authorization and )
- 设定超时时间、失败次数、版本
R0(config)#ip ssh time-out 120
R0(config)#ip ssh authentication-retries 5
R0(config)#ip ssh version 2
- 设置连接线路
R0(config)#line vty 0 15
R0(config)#transport input ssh
仅允许使用ssh登录,如果还要允许telnet登录,使用命令。
R0(config)#transport input ssh telnet
远程登录后,特权模式不设置密码,是不能登录特权模式的。
路由器接口操作
- 查看接口
Router0#show running-config
查看running-config配置,可以看到当前路由器有哪些接口
- 选择接口,会进入接口配置模式
R0(config)#interface ?
Dot11Radio Dot11 interface # 无线网卡接口
Ethernet IEEE 802.3 # 以太网接口
FastEthernet FastEthernet IEEE 802.3 # 快速以太网接口
GigabitEthernet GigabitEthernet IEEE 802.3z # 千兆以太网接口
Loopback Loopback interface # 回环网卡接口
Serial Serial # 串行接口
Tunnel Tunnel interface # 隧道接口
Virtual-Template Virtual Template interface # 虚拟模板接口
Vlan Catalyst Vlans # vlan 接口
range interface range command # 接口范围
- 接口描述
R0(config)#interface fastEthernet 0/0
R0(config-if)#description Test router
R0(config-if)#^Z
... 省略 ...
!
interface FastEthernet0/0
description Test router
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
... 省略 ...
- do 命令
每个命令的执行都必须在特定的命令模式之中,比如 show running-config 命令就只能在特权模式中执行。否则
R0#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R0(config)#show running-config
^
% Invalid input detected at '^' marker.
但是可以是由 do 命令可以让命令在其他模式中运行,例如:
R0(config)#do show running-config
Building configuration...
Current configuration : 1018 bytes
!
version 12.4
... 省略 ...
- 激活接口
接口默认是关闭状态的,需要激活
R0(config)#interface FastEnthernet 0/1
R0(config-if)#do show interface FastEthernet 0/1
FastEthernet0/1 is administratively down, line protocol is down (disabled)
... 省略 ...
R0(config-if)#no shutdown
R0(config-if)#do show interface FastEthernet 0/1
FastEthernet0/1 is up, line protocol is up (connected)
... 省略 ...
档接口激活后,如果没有配置IP地址,我们可以看到接口显式激活,但是连接协议是关闭的,所以一定要在激活接口后配置IP地址。
- 给接口配置IP地址
R0(config)#interface FastEthernet 0/1
R0(config-if)#ip address 192.168.2.1 255.255.255.0
R0(config-if)#do show interface fastethernet 0/1
FastEthernet0/1 is up, line protocol is up (connected)
Hardware is Lance, address is 000d.bda5.0502 (bia 000d.bda5.0502)
Internet address is 192.168.2.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00,
Last input 00:00:08, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
- 时钟频率
时钟频率在生成环境下不用配置,一般由服务器运营商来进行控制。时钟频率只对串口连接的路由有效,串口是用于老式的广域网连接的,主要用于E1网络(带宽 2.048Mbps)。现在基本都使用光纤接口取代了。
如果使用 Seria 串口,则在 DCE(数据通信设备)端需要配置时钟频率,但是DTE(数据终端设备)端不需要配置。在实现环境下,如果使用串口连接两个路由,则需要在DCE口配置时钟频率。
R1#show controllers serial 1/0/0
Interface Serial1/0/0
Hardware is PowerQUICC MPC860
DTE V.35 TX and RX clocks detected
查看 R1 路由 serial 1/0/0 接口的情况,可以看到这个路由器的 s 1/0/0 接口是 DTE 设备
R0#show controllers serial 1/0/0
Interface Serial1/0/0
Hardware is PowerQUICC MPC860
DCE V.35, clock rate 2000000
查看 R0 路由 serial 1/0/0 接口的情况,可以看到这个路由器的 s 1/0/0 接口是 DCE 设备。如果是 DCE 端,则要配置时钟频率,单位是 “bit/s”
R0(config)#interface serial 1/0/0
R0(config-if)#clock rate 64000
R0(config-if)#do show controllers serial 1/0/0
Interface Serial1/0/0
Hardware is PowerQUICC MPC860
DCE V.35, clock rate 64000
串口设备还可以通过 bandwidth 命令来配置带宽,注意这个命令的单位是千位
R0(config)#interface serial 1/0/0
R0(config-if)#bandwidth ?
<1-10000000> Bandwidth in kilobits
R0(config-if)#bandwidth 1000
保存与删除
- 保存设备
R0#copy running-config start-config
running-config 是运行配置,保存在 DRAM当中,重启之后会失效。执行此命令会把 running-config 复制为 startup-config,startup-config 是启动配置,保存在NVRAM当中。永久生效。
R0#show startup-config
查看启动配置
- 删除配置
R0#erase startup-config
R0#show startup-config
startup-config is not present
- 重启路由器
R0#reload
查看和验证配置
- ping 联通性检测
R1#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
ping 通会显示感叹号,一般是ping 5次。
R1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
ping 不通会显示点(.)。
- traceroute 域名或IP
测试路由路径
R1#traceroute 192.168.2.1
Type escape sequence to abort.
Tracing the route to 192.168.2.1
1 192.168.2.1 8 msec 1 msec 1 msec
-
telnet IP 或域名 端口
远程管理,或远程探测 -
查看接口的参数和配置
R1#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up (connected) # 端口状态
Hardware is Lance, address is 0009.7c6b.cd01 (bia 0009.7c6b.cd01)
Internet address is 192.168.2.1/24 # 端口IP和子网掩码
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, # 最大传输单元
reliability 255/255, txload 1/255, rxload 1/255 # 可靠性 网络负荷
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00,
... 省略 ...
- 清除接口计数器
R1#clear counters fastethernet 0/0
- 查看 IP 信息
R1#show ip interface
FastEthernet0/0 is up, line protocol is up (connected)
Internet address is 192.168.2.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
... 省略 ...
上面的这个命令不直观,可以在添加一个子命令,查看列表
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.2.1 YES manual up up
FastEthernet0/1 192.168.10.2 YES manual up up
FastEthernet1/0 unassigned YES unset administratively down down
FastEthernet1/1 unassigned YES unset administratively down down
Serial1/0/0 unassigned YES unset up up
Serial1/1/0 unassigned YES unset down down
Vlan1 unassigned YES unset administratively down down
- 查看所有接口上的协议
可以用于查询每个端口的状态和配置的IP地址
R1#show protocol
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 192.168.2.1/24
FastEthernet0/1 is up, line protocol is up
Internet address is 192.168.10.2/24
FastEthernet1/0 is administratively down, line protocol is down
FastEthernet1/1 is administratively down, line protocol is down
Serial1/0/0 is up, line protocol is up
Serial1/1/0 is down, line protocol is down
Vlan1 is administratively down, line protocol is down
网友评论