1019 数字黑洞 (20 分)
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,104) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
using namespace std;
#define anwser 6174
bool cmp(int a,int b){
return a>b;
}
int main(){
string N1;
int N2[4]={0};
int N3[4]={0};
int Ans=-1;
cin>>N1;
for(int i=0;i<N1.size();++i){
N2[i]=N1[i]-'0';
N3[i]=N1[i]-'0';
}
while (Ans!=anwser&&Ans!=0)
{
int Sum=0,Sub=0;
sort(N2,N2+4,cmp);
sort(N3,N3+4);
for(int i=0;i<4;++i){
Sum+=N3[i]*pow(10,i);
Sub+=N2[i]*pow(10,i);
}
Ans=Sum-Sub;
int temp[4];
temp[0]=Ans/1000;
temp[1]=Ans%1000/100;
temp[2]=Ans%100/10;
temp[3]=Ans%10;
if(Ans!=anwser)
cout<<N2[0]<<N2[1]<<N2[2]<<N2[3]<<" - "<<N3[0]<<N3[1]<<N3[2]<<N3[3]<<" = "<<temp[0]<<temp[1]<<temp[2]<<temp[3]<<endl;
else
cout<<N2[0]<<N2[1]<<N2[2]<<N2[3]<<" - "<<N3[0]<<N3[1]<<N3[2]<<N3[3]<<" = "<<temp[0]<<temp[1]<<temp[2]<<temp[3];
for(int i=0;i<4;++i){
N2[i]=temp[i];
N3[i]=temp[i];
}
}
system("pause");
return 0;
}
网友评论