美文网首页
#hihocoder1400# : Composition

#hihocoder1400# : Composition

作者: diskang | 来源:发表于2016-10-11 16:59 被阅读217次

    1400 : Composition

    • 时间限制:10000ms
    • 单点时限:1000ms
    • 内存限制:256MB

    描述

    Alice writes an English composition with a length of N characters. However, her teacher requires that M illegal pairs of characters cannot be adjacent, and if 'ab' cannot be adjacent, 'ba' cannot be adjacent either.
    In order to meet the requirements, Alice needs to delete some characters.
    Please work out the minimum number of characters that need to be deleted.

    输入

    The first line contains the length of the composition N.
    The second line contains N characters, which make up the composition. Each character belongs to 'a'..'z'.
    The third line contains the number of illegal pairs M.
    Each of the next M lines contains two characters ch1
    and ch2
    ,which cannot be adjacent.
    For 20% of the data: 1 ≤ N ≤ 10
    For 50% of the data: 1 ≤ N ≤ 1000
    For 100% of the data: 1 ≤ N ≤ 100000, M ≤ 200.

    输出

    One line with an integer indicating the minimum number of characters that need to be deleted.

    样例提示

    Delete 'a' and 'd'.

    样例输入

    5
    abcde
    3
    ac
    ab
    de

    样例输出

    2

    我思路是这样的 求出满足条件的最长子序列 然后与原始长度相减即可
    假设valid(ch1, ch2)表示ch1、ch2可以连在一起(很好实现,二维2626的bool矩阵即可)
    用一个数组dp[26]表示目前以'a'+i结尾的最长子序列的长度,dp初始化为全0。 然后线性扫描原始串,每次更新table表即可
    复杂度
    O(N26)**

    #define _CRT_SECURE_NO_WARNINGS
    #include <iostream>
    #include <vector>
    #include <string>
    #include <algorithm>
    #include <functional>
    #include <array>
    #include <list>
    
    using namespace std;
    
    char table[100001];
    int dp[26] = {0};   //以第'a'+i个字符结尾,最长的子序列
    bool m[26][26];     //用来判断两个char是否可以相连
    int main(int argc, char **argv)
    {
        int N = 0, M = 0;
        scanf("%d\n", &N);
        scanf("%s", table);
        //cin >> table;
        //cin >> M;
        scanf("%d\n", &M);
        /*for (int i = 0; i != 26; ++i)
        {
            for (int j=0; j!=26; ++j)
            {
                m[i][j] = false;
            }
        }*/
        for (int i=0; i!=M; ++i)
        {
            char ch1, ch2;
            //scanf("%c%c\n", &ch1, &ch2);
            cin >> ch1 >> ch2;
            m[ch1 - 'a'][ch2 - 'a'] = true;
            m[ch2 - 'a'][ch1 - 'a'] = true;
        }
    
        for (int i=0; i<N; ++i)
        {
            char ch1 = table[i];
            int temp = 1;
            for (int j=0; j!=26; ++j)
            {
                if (m[ch1 - 'a'][j])
                {
                    continue;
                }
                else
                {
                    temp = max(temp, dp[j] + 1);
                }
            }
            dp[ch1 - 'a'] = temp;
        }
    
        cout << N - *max_element(dp, dp+26) << endl;
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:#hihocoder1400# : Composition

          本文链接:https://www.haomeiwen.com/subject/zfsbyttx.html