美文网首页
PAT 甲级 刷题日记|A 1143 Lowest Common

PAT 甲级 刷题日记|A 1143 Lowest Common

作者: 九除以三还是三哦 | 来源:发表于2021-08-18 09:38 被阅读0次

    单词积累

    respectively 分别地 各自地

    descendants 后代 晚辈 子节点

    题目

    The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

    A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    Given any two nodes in a BST, you are supposed to find their LCA.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

    Output Specification:

    For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

    Sample Input:

    6 8
    6 3 1 2 5 4 8 7
    2 5
    8 7
    1 9
    12 -3
    0 8
    99 99
    结尾无空行
    

    Sample Output:

    LCA of 2 and 5 is 3.
    8 is an ancestor of 7.
    ERROR: 9 is not found.
    ERROR: 12 and -3 are not found.
    ERROR: 0 is not found.
    ERROR: 99 and 99 are not found.
    结尾无空行
    

    思路

    求二叉排序树的最低公共父节点,常规思路是从根节点开始遍历,遍历到第一个能把两个数从中间分开的节点,就找到了结果。但是该条思路有两个测试样例(3和4)超时了。不过作为一般思路,仍有借鉴意义。

    通过研究题解,发现有更巧妙的做法,无需建树。题目给定了前序序列和待查询数a和b,遍历前序序列,找到第一个大小位于a和b间的数,就是结果。该做法全篇无树,但又巧用树的性质,解决了树的问题。

    为什么是第一个呢?因为前序序列,遇到的首先是根,这个根会把后续的树分成左右子树,a和b也会被分开,不会再出现共同的父节点。

    代码(AC版本)

    #include<bits/stdc++.h>
    using namespace std;
    
    map<int, bool> mp;
    
    int main() {
        int m, n, u, v, a;
        scanf("%d %d", &m, &n);
        vector<int> pre(n);
        for (int i = 0; i < n; i++) {
            scanf("%d", &pre[i]);
            mp[pre[i]] = true;
        }
        while (m--) {
            scanf("%d %d", &u, &v);
            for (int j = 0; j < n; j++) {
                a = pre[j];
                if ((a >= v && a <= u) || (a >= u && a <= v)) break;
            }
            if (mp[u] == false && mp[v] == false)
                printf("ERROR: %d and %d are not found.\n", u, v);
            else if (mp[u] == false || mp[v] == false)
                printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
            else if (a == u || a == v)
                printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
            else
                printf("LCA of %d and %d is %d.\n", u, v, a);
        }
    }
    

    代码2(常规超时版)

    #include <bits/stdc++.h>
    using namespace std;
    
    int N, M;
    const int maxn = 10003;
    int num[maxn];
    map<int,int> vis;
    vector<int> ans;
    
    struct node{
        int data;
        node* lchild;
        node* rchild;
        node(int d): data(d), lchild(NULL), rchild(NULL) {
        }
    };
    
    void insert(node* &root, int v) {
        if (root == NULL) {
            root = new node(v);
            return;
        }
        if (v < root->data) {
            insert(root->lchild, v);
        } else if (v >= root->data) {
            insert(root->rchild, v);
        }
    }
    
    void search(node* root, int a, int b) {
        if (a == root->data) {
            printf("%d is an ancestor of %d.\n", a, b);
            return;
        }else if (b == root->data) {
            printf("%d is an ancestor of %d.\n", b, a);
            return;
        }else if (a < root->data && b < root->data) {
            search(root->lchild, a, b);
        } else if (a > root->data && b > root->data) {
            search(root->rchild, a, b);
        } else {
            printf("LCA of %d and %d is %d.\n", a, b, root->data);
        }
    }
    
    
    int main() {
        cin>>N>>M;
        node* root = NULL;
        for (int i = 0; i < M; i++) {
            cin>>num[i];
            vis[num[i]] = 1;
            insert(root, num[i]);
        }
        while (N--) {
            int n1, n2;
            cin>>n1>>n2;
            if (vis[n1] == 1 && vis[n2] == 1) {
                search(root, n1, n2);
            } else if (vis[n1] == 1) {
                printf("ERROR: %d is not found.\n", n2);
            } else if (vis[n2] == 1) {
                printf("ERROR: %d is not found.\n", n1);
            } else {
                printf("ERROR: %d and %d are not found.\n", n1, n2);
            }
            
        }
    }
    

    相关文章

      网友评论

          本文标题:PAT 甲级 刷题日记|A 1143 Lowest Common

          本文链接:https://www.haomeiwen.com/subject/arwsbltx.html