描述
输入一行字符,统计出其中数字字符的个数。
输入
一行字符串,总长度不超过255。
输出
输出为1行,输出字符串里面数字字符的个数。
样例输入
Peking University is set up at 1898.
样例输出
4
C语言
#include <stdio.h>
#define is_number(ch) (('0'<=(ch)) && ((ch)<='9')) // 判断字符是否为数字
#define size 256
int main(void)
{
char str[size];
gets(str);
int count = 0;
int i;
for (i=0; str[i]; i++){
if (is_number(str[i])){
count++;
}
}
printf("%d\n", count);
return 0;
}
网友评论