美文网首页
1081 Rational Sum (20 分)(数学题)

1081 Rational Sum (20 分)(数学题)

作者: virgilshi | 来源:发表于2018-09-30 21:11 被阅读0次
1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
#include<iostream>
#include <cmath>
using namespace std;
int gcd(int a,int b) {
    return b==0?a:gcd(b,a%b);
}
int main(){
    int n;
    cin>>n;
    int a,b;
    scanf("%d/%d",&a,&b);
    int t=gcd(a,b);
    a=a/t,b=b/t;
    for(int i=1;i<n;i++){
        int c,d;
        scanf("%d/%d",&c,&d);
        a=a*d+b*c;
        b=b*d;
        int t=gcd(a,b);
        a=a/t,b=b/t;
    }
    if(a%b==0) printf("%d",a/b);
    else{
        if(abs(a)>abs(b)){
            if(a>0) printf("%d %d/%d",a/b,a-a/b*b,b);
            else{
                a=-a;
                printf("-%d %d/%d",a/b,a-a/b*b,b);
            }
        }else printf("%d/%d",a,b);
    }
    return 0;
}

相关文章

网友评论

      本文标题:1081 Rational Sum (20 分)(数学题)

      本文链接:https://www.haomeiwen.com/subject/bihgoftx.html