美文网首页
CUC-SUMMER-12-A

CUC-SUMMER-12-A

作者: Nioge | 来源:发表于2017-08-18 23:33 被阅读0次
    A - How Many Tables
    HDU-1213

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
    Sample Input
    2
    5 3
    1 2
    2 3
    4 5

    5 1
    2 5
    Sample Output
    2
    4


    题意:认识的人在一桌,一共要多少桌

    解法:并查集,求几个集合

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int pre[1005];
    int find(int x){
        if(x!=pre[x])
            pre[x]=find(pre[x]);
        return pre[x];
    }
    int main()
    {
        int num;
        scanf("%d",&num);
        while(num--){
            memset(pre,0,sizeof(pre));
            int n,m,x,y,ans=0;
            scanf("%d%d",&n,&m);
            for(int i=1;i<=n;i++)
                pre[i]=i;
            for(int i=0;i<m;i++){
                scanf("%d%d",&x,&y);
                int px=find(x);
                int py=find(y);
                if(px!=py)
                    pre[px]=py;
            }
            for(int i=1;i<=n;i++)
                if(pre[i]==i)
                    ans++;
            printf("%d\n",ans);
        }
    }
    

    相关文章

      网友评论

          本文标题:CUC-SUMMER-12-A

          本文链接:https://www.haomeiwen.com/subject/bxpzrxtx.html