1140 Look-and-say Sequence(20 分)
Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ...
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.
Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.
Sample Input:
1 8
Sample Output:
1123123111
题意:
D是0到9中除1以外的数字。第n+1个数字是第n个数字的一种描述。举个例子,第二个数表示第一个数中只有一个D,因此为D1;第二个数由一个D(D1)和一个1(11)组成,因此第三个数是D111;第四个数是D113,它由一个D(D1),三个1(13)组成;下一个是D11231。
你被要求计算第n个数对于给定的D。
思路:
用一个vector接收。每一次从头开始遍历。
注意一下vector数组结尾时的数据也要进行保存。
题解:
#include<cstdlib>
#include<cstdio>
#include<vector>
using namespace std;
int main() {
int d, n;
scanf("%d %d", &d, &n);
vector<int> num;
num.push_back(d);
for (int i = 1; i < n; i++) {
vector<int> temp;
int v = num[0];
int cnt = 0;
for (int j = 0; j < num.size(); j++) {
if (num[j] == v) cnt++;
else{
temp.push_back(v);
temp.push_back(cnt);
cnt = 1;
v = num[j];
}
//如果到达结尾时,要最后一组数据进行push
if (j == num.size() - 1) {
temp.push_back(v);
temp.push_back(cnt);
}
}
num = temp;
}
for (int i = 0; i < num.size(); i++) {
printf("%d", num[i]);
}
return 0;
}
网友评论