PTA 1029 旧键盘 (20 分)

作者: freesan44 | 来源:发表于2021-09-05 11:14 被阅读0次

    题目

    旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

    输入格式:
    输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

    输出格式:
    按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

    输入样例:
    7_This_is_a_test
    _hs_s_a_es
    结尾无空行
    输出样例:
    7TI
    结尾无空行
    

    解题思路

    input1Str = input()
    input2Str = input()
    # input1Str = "7_This_is_a_test"
    # input2Str = "hssaes"
    # zhizhen1 = 0
    # zhizhen2 = 0
    # resList = []
    # while zhizhen1 < len(input1Str) and zhizhen2 < len(input2Str):
    #     char = input1Str[zhizhen1]
    #     if char == input2Str[zhizhen2]:
    #         zhizhen2 += 1
    #     else:#如果不相等,放入结果数组里面
    #         if char.isalpha() == True:#字母转成大写
    #            char = char.upper()
    #         if char not in resList:
    #             resList.append(char)
    #     zhizhen1 += 1
    # print("".join(resList))
    
    input1Str =input1Str.upper()
    input2Str =set(input2Str.upper())
    resList = []
    for i in input1Str:#把所有字符形成唯一数组
        if i not in resList:
            resList.append(i)
    for i in input2Str:#删掉重复的
        resList.remove(i)
    print("".join(resList))
    

    相关文章

      网友评论

        本文标题:PTA 1029 旧键盘 (20 分)

        本文链接:https://www.haomeiwen.com/subject/cwmciltx.html