编写一个程序,函数zxb(x),其中x 是一个n位的数,函数功能是:求整数x的后n-1喂,如果x是一位数则返回0,要求输入输出均在主函数中完成。样例输入:9 样例输出:0 样例输入:6734 样例输出:734
样例输入:1000 样例输出:0 样例输入:10101 样例输出:101
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int zxb(int x);
int x,c;
cin>>x;
c=zxb(x);
cout<<"后n-1位:"<<c<<endl;
return 0;
}
int zxb(int x)
{
int a,b,n=0,m;
b=x;
if(x<10)
a=0;
else
while(b>0)
{
b=b/10;
n++;
}
m=x%int(pow(10,n-1));
a=m;
return a;
}
网友评论